Choose the best route(HDU-2680)

Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
1 -1
 

題意:給出n,m,s,代表有n個車站,m條路線,s爲終點,然後m行代表路線和花費,單向邊,最後給出k個數代表能選擇的出發點


思路:Dijkstra算法;


#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int inf = 100000000;
int n,m,s;
int map[1005][1005];
int vis[1005],cast[1005];

void Dijkstra()
{
    int i,j,minn,pos;
    memset(vis,0,sizeof(vis));
    vis[0] = 1;
    for(i = 0; i<=n; i++)
        cast[i] = map[0][i];
    for(i = 0; i<=n; i++)
    {
        minn = inf;
        for(j = 0; j<=n; j++)
        {
            if(cast[j]<minn && !vis[j])
            {
                pos = j;
                minn = cast[j];
            }
        }
        vis[pos] = 1;
        for(j = 0; j<=n; j++)
        {
            if(cast[pos]+map[pos][j]<cast[j] && !vis[j])
                cast[j] = cast[pos]+map[pos][j];
        }
    }
}


int main()
{
    int i,j;
    int x,y,t;
    while(~scanf("%d%d%d",&n,&m,&s))
    {
        for(i = 0; i<=n; i++)
            for(j = 0; j<=n; j++)
                map[i][j] = inf;
        while(m--)
        {
            scanf("%d%d%d",&x,&y,&t);
            if(t<map[x][y])
                map[x][y] = t;
        }
        scanf("%d",&m);
        while(m--)
        {
            scanf("%d",&x);
            map[0][x] = 0;
        }
        Dijkstra();
        if(cast[s] == inf)
            printf("-1\n");
        else
            printf("%d\n",cast[s]);
    }

    return 0;
}



發佈了77 篇原創文章 · 獲贊 11 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章