POJ 3041 - Asteroids

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.


OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).


題意:有一個小行星帶分佈成一個矩形在XOY座標軸上,每條激光從 X軸或 Y軸上的某一點射出,橫向或縱向,可以將在這同一條直線上的小行星全部擊毀,問最少幾次攻擊。給出 n 和 k 分別代表 n*n 的矩陣,k 個小行星,下面有 k 行,每行是 x y 座標。

簡單的二分圖匹配,每個點集一定有頂點,將每個頂點進行一次射擊即可。

#include <cstdio>
#include <cstring>

bool maps[500 + 5][500 + 5], vis[500 + 5];
int match[500 + 5];
int n;

bool DFS(int u)
{
    for (int v = 1; v <= n; ++v)
    {
        if (maps[u][v] && !vis[v])///v沒有訪問過
        {
            vis[v] = true;
            if (match[v] == -1 || DFS(match[v]))///v還能構成別的點集
            {
                match[v] = u;
                return true;
            }
        }
    }
    return false;
}

int maxmatch()
{
    int ret = 0;
    memset(match, -1, sizeof(match));
    for (int u = 1; u <= n; ++u)
    {
        memset(vis, false, sizeof(vis));
        if (DFS(u))
            ret++;
    }
    return ret;
}

int main()
{
    int k;
    while (scanf("%d%d", &n, &k) != EOF)
    {
        memset(maps, false, sizeof(maps));
        for (int i = 0; i < k; ++i)
        {
            int a, b;
            scanf("%d%d", &a, &b);
            maps[a][b] = true;
        }
        int ans = maxmatch();
        printf("%d\n", ans);
    }
    return 0;
}


發佈了158 篇原創文章 · 獲贊 23 · 訪問量 6萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章