HDU 1532 - Drainage Ditches

Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.



Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.



Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.



Sample Input
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10


Sample Output
50

題意:給出 n 條水道和 m 個頂點,每條水道給出起始點、終點和最大流量,請求出從 1 到 n 點中的最大流量。

初次接觸最大網絡流,並不是很熟。。。用了DFS和Ford-Fulkerson。

#include <cstdio>
#include <cstring>

int cru[200 + 5][200 + 5];
bool vis[200 + 5];
const int INF = 0x3f3f3f3f;

int DFS(int s, int t, int n, int low)
{
    int flow;
    if (s == t)
        return low;
    if (vis[s] == true)
        return 0;
    vis[s] = true;

    for (int i = 1; i <= n; ++i)
    {
        if ((cru[s][i] > 0) && (flow = DFS(i, t, n, low > cru[s][i] ? cru[s][i] : low)))
        {
            cru[s][i] -= flow;///水道已經佔用了的流量
            cru[i][s] += flow;///反方向擁有的流量
            return flow;
        }
    }
    return 0;
}

int max_flow(int s, int t, int n)
{
    memset(vis, false, sizeof(vis));
    int maxflow = 0;
    int flow;

    while (flow = DFS(s, t, n, INF))
    {
        memset(vis, false, sizeof(vis));
        maxflow += flow;
    }
    return maxflow;
}

int main()
{
    int n, m;
    while (scanf("%d%d", &n, &m) != EOF)
    {
        memset(cru, 0, sizeof(cru));
        for (int i = 1; i <= n; ++i)
        {
            int from, to, v;
            scanf("%d%d%d", &from, &to, &v);
            cru[from][to] += v;
        }
        printf("%d\n", max_flow(1, m, m));
    }
    return 0;
}

/*
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10
*/


 

發佈了158 篇原創文章 · 獲贊 23 · 訪問量 6萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章