POJ2352

Stars
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 36355   Accepted: 15810

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.


You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.



簡單地讀一下題目意思就是紅色那段說的4和2的level是1,5的level是3,所以就是統計一下該點的左下角星星個數,然後輸出那個lvevl的星星數目。
#include<stdio.h>
#include<stdlib.h>
#define MAX 32005
int a[MAX]= {0},c[MAX]= {0};
int lowbit(int x)
{
    return x&(-x);
}
int sum(int i)
{
    int s;
    while(i>0)
    {
        s=s+c[i];
        i=i-lowbit(i);
    }
    return s;
}
void add(int x)
{
    while(x<=MAX)
    {
        ++c[x];
        x=x+lowbit(x);
    }
}
int main()
{
    int x,y,i,n;
    scanf("%d",&n);
    for(i=0; i<MAX; i++)
        a[i]=c[i]=0;
    for(i=0; i<n; i++)
    {
        scanf("%d%d",&x,&y);
        a[sum(++x)]++;
        add(x);
    }
    for(i=0; i<n; i++)
    {
        printf("%d\n",a[i]);
    }
    return 0;
}


發佈了41 篇原創文章 · 獲贊 14 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章