POJ3268

Silver Cow Party
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 14455   Accepted: 6511

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ XN). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.


#include<stdio.h>
#define M 99999999
int map[1002][1002]={0},mapp[1002][1002]={0};
int d[1002],dt[1002];

void dijistra(int d[],int g[][1002],int n,int v)
{
	int i,j;
	int ss[1002];
	int min;
	int u;

	for(i=1;i<=n;i++)
	{
		d[i]=M;
		ss[i]=0;
	}
	d[v]=0;
	for(i=1;i<=n;i++)
	{
		min=M;
		for(j=1;j<=n;j++)
		{
			if(ss[j]==0&&d[j]<min)
			{
				min=d[j];
				u=j;
			}
		}
		ss[u]=1;
		for(j=1;j<=n;j++)
		{
			if(d[u]+g[u][j]<d[j])
			{
				d[j]=d[u]+g[u][j];
			}
		}
	}
}
int main()
{
	int i,j,n,edge,party,cost,u,v;
	int max;

	scanf("%d %d %d",&n,&edge,&party);
	for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
		{
			map[i][j]=M;
			mapp[i][j]=M;
		}
	for(i=0;i<=edge;i++)
	{
		scanf("%d%d",&u,&v);
		scanf("%d",&map[u][v]);
		mapp[v][u]=map[u][v];
	}
	dijistra(d,map,n,party);
	dijistra(dt,mapp,n,party);
	max=0;
	for(i=1;i<=n;i++)
	{
		if(max<d[i]+dt[i])
			max=d[i]+dt[i];
	}
	printf("%d",max);
	return 0;
}

不是很會,仿照的寫的,感覺迪傑斯特拉還是不怎麼好寫,理解起來還好
發佈了41 篇原創文章 · 獲贊 14 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章