[POJ] 2485 Highways

題目:
The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They’re planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.
Input
The first line of input is an integer T, which tells how many test cases followed.
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.
Output
For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.
Sample Input
1

3
0 990 692
990 0 179
692 179 0
Sample Output
692
Hint
Huge input,scanf is recommended.

分析:額,一開始沒讀懂題目,什麼最小化最長的道路。然後發現就是求最小生成樹的最長的道路。然後RE了3次,數組開小了!

代碼:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std ;

int a[1000][1000];
class edge{
    public:
    int u ; 
    int v ; 
    int w ;
};
int f[1000];
edge e[50000];

bool compare(edge x , edge y){
    if(x.w<y.w) return true ; 
    else return false ; 
}

int getf(int x){
    if(x==f[x]) return x ; 
    else return f[x] = getf(f[x]);
}

int merge(int x , int y){
    int tx = getf(x);
    int ty = getf(y);
    if(tx!=ty){
        f[ty] = tx ;
        return 1 ;
    }
    else return 0 ; 
}

int main(){
    //freopen("in.txt","r",stdin);
    int t , n ; 
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        //¶ÁÈëÊý¾Ý 
        for(int i = 1 ; i <= n ; i++){
            for(int j = 1 ; j <= n ; j++) scanf("%d",&a[i][j]);
        }
        int num = 0 ;
        for(int i = 1;  i <= n-1 ; i++){
            for(int j = i+1 ; j <= n ; j++) {
                e[++num].u = i , e[num].v = j , e[num].w = a[i][j];
            }
        }
        //³õʼ»¯
        for(int i = 1 ; i <= n ; i++) f[i] = i ;
        sort(e+1,e+1+num,compare);
        //for(int i = 1 ; i <= num ; i++) printf("%d ",e[i].w); 
        int count = 0 ; 
        int ans ;
        for(int i = 1 ; i <= num ; i++){
            if(merge(e[i].u,e[i].v)){
                count ++ ; 
            }
            if(count==n-1){
                ans = e[i].w ; 
                break;
            }
        }
        printf("%d\n",ans);

    }
    return 0 ; 
}
發佈了52 篇原創文章 · 獲贊 0 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章