POJ 3020 Antenna Placement(二分圖最小路徑覆蓋)

Description

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them. 
 
Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered? 

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space. 

Output

For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

Sample Input

2
7 9
ooo**oooo
**oo*ooo*
o*oo**o**
ooooooooo
*******oo
o*o*oo*oo
*******oo
10 1
*
*
*
o
*
*
*
*
*
*

Sample Output

17
5



題目大意:

        給定一個圖,要求用最少的1*2的天線覆蓋所有的‘*’區域

解題思路:

        可以轉化成二分圖來考慮,所有的星號都分成了“兩份”,構成了二分圖的AB集,相鄰的星號(不包括自身與自身)在二分圖AB集中存在關係,建立邊(其實是拆點法構建二分圖),則問題轉化成了求二分圖最小路徑覆蓋問題,因爲最小路徑覆蓋=頂點數-最大匹配數,因爲是無向圖,所以最大匹配數還要再除2,這樣問題就變成了求二分圖最大匹配了,直接匈牙利算法


#include <iostream>
#include <fstream>
#include <cstdio>
#include <cmath>
#include <map>
#include <set>
#include <bitset>
#include <ctime>
#include <cstring>
#include <algorithm>
#include <stack>
#include <queue>
#include <vector>
#include <list>

#define STD_REOPEN() freopen("../in.in","r",stdin)
#define STREAM_REOPEN fstream cin("../in.in")
#define INF 0x3f3f3f3f
#define _INF 63
#define eps 1e-8
#define MAX_V 100010
#define MAX_P 510
#define MAX_E 10010
#define MAX 32000
#define MOD_P 3221225473
#define MOD 9901

using namespace std;

int dx[]={0,1,0,-1};
int dy[]={1,0,-1,0};
bool s[MAX_P][MAX_P];
char mp[MAX_P][MAX_P];
int idx[MAX_P][MAX_P];
bool vis[MAX_P];
int link[MAX_P];
int n,h,w;

bool dfs(int x)
{
	for(int i=1;i<=n;i++)
	{
		if(s[x][i]&&!vis[i])
		{
			vis[i]=true;
			if(link[i]==-1||dfs(link[i]))
			{
				link[i]=x;
				return true;
			}
		}
	}
	return false;
}

int main()
{
	//STD_REOPEN();
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d %d",&h,&w);
		memset(idx,0,sizeof(idx));
		memset(link,-1,sizeof(link));
		memset(s,0,sizeof(s));
		for(int i=1;i<=h;i++)
			scanf("%s",mp[i]+1);
		n=0;
		for(int i=1;i<=h;i++)
			for(int j=1;j<=w;j++)
				if(mp[i][j]=='*')
					idx[i][j]=++n;
		for(int i=1;i<=h;i++)
			for(int j=1;j<=w;j++)
				if(mp[i][j]=='*')
					for(int k=0;k<4;k++)	//拆點構圖
					{
						int px=i+dx[k];
						int py=j+dy[k];
						s[idx[i][j]][idx[px][py]]=true;
					}
		int ans=0;
		for(int i=1;i<=n;i++)
		{
			memset(vis,0,sizeof(vis));
			if(dfs(i))
				ans++;
		}
		//cout<<n<<" "<<ans<<endl;
		printf("%d\n",n-ans/2);
	}

    return 0;
}


發佈了104 篇原創文章 · 獲贊 28 · 訪問量 7萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章