Catch That Cow

Catch That Cow

Time Limit:2000MS    Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a pointN (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 orX + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N andK

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes. 

題意:人在N的位置,牛在K的位置,人有三種前進方式,+1、-1、*2,求人找到牛的最少的步數
#include"queue"
#include"cstdio"
#include"cstring"
#include"iostream"
#include"algorithm"

using namespace std;

#define MAXN 100000

struct node
{
    int loc,t;
};

int st,en;
bool vis[MAXN + 5];

queue < node > q;

int bfs(int st)
{
    while(!q.empty())
    {
        q.pop();
    }
    node a;
    a.loc = st;
    a.t = 0;
    vis[a.loc] = true;
    q.push(a);
    while(!q.empty())
    {
        node b = q.front();
        q.pop();
        if(b.loc == en)
        {
            return b.t;
        }
        int l;
        l = b.loc + 1; //情況1,前進一步
        if(l > 0 && l < MAXN && !vis[l])
        {
            node c;
            c.loc = l;
            c.t = b.t + 1;
            vis[l] = true;
            q.push(c);
        }
        l = b.loc - 1; //情況2,後退一步
        if(l >= 0 && l <= MAXN && !vis[l])
        {//因爲是後退,所以l可以等於0,之前寫的>0,那麼1,0這組樣例就會出錯
            node c;
            c.loc = l;
            c.t = b.t + 1;
            vis[l] = true;
            q.push(c);
        }
        l = b.loc << 1;
        if(l >= 0 && l <= MAXN && !vis[l]) //情況3,*2
        {
            node c;
            c.loc = l;
            c.t = b.t + 1;
            vis[l] = true;
            q.push(c);
        }
    }
}

int main()
{
    while(~scanf("%d%d",&st,&en))
    {
        memset(vis,false,sizeof(vis)); //BFS被訪問過的就不會再次被訪問,需要標記
        printf("%d\n",bfs(st));
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章