poj 2318 TOYS(叉积+二分)

TOYS
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 10292   Accepted: 4934

Description

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.
 
 
题意:一个矩形,有被n条直线分成n+1个区域,给出m个点的座标,问落在各个区域的点数有多少。
思路:利用叉积的性质,叉积>0,三点逆时针,点在直线左边,叉积小于0,三点顺时针,点在直线右边。二分直线的下标即可。
 
 
AC代码:
#include <iostream>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <queue>
#include <algorithm>
#define ll long long

using namespace std;

const int INF = 1e9;
const int maxn = 5005;


int n, m, x1, y1, x2, y2;
struct point{
    int x, y;
};
struct line{
    point a, b;
}l[maxn];
int cnt[maxn];
int Multi(point p1, point p2, point p0){
    return (p1.x - p0.x) * (p2.y - p0.y) - (p2.x - p0.x) * (p1.y - p0.y);
}
void solve(point a){
    int low = 0, high = n - 1, mid;
    while(low <= high)
    {
        mid = (low + high) >> 1;
        if(Multi(a, l[mid].a, l[mid].b) > 0) low = mid + 1;
        else high = mid - 1;
    }
    if(Multi(a, l[mid].a, l[mid].b) < 0) cnt[mid]++;
    else cnt[mid + 1]++;
}
int main()
{
    point a;
    while(scanf("%d", &n), n)
    {
        scanf("%d%d%d%d%d", &m, &x1, &y1, &x2, &y2);
        l[0].a.x = x1, l[0].a.y = y1;
        l[0].b.x = x1, l[0].b.y = y2;
        for(int i = 0; i < n; i++)
        {
            scanf("%d%d", &l[i].a.x, &l[i].b.x);
            l[i].a.y = y1, l[i].b.y = y2;
        }
        memset(cnt, 0, sizeof(cnt));
        while(m--)
        {
            scanf("%d%d", &a.x, &a.y);
            solve(a);
        }
        for(int i = 0; i <= n; i++)
        printf("%d: %d\n", i, cnt[i]);
        puts("");
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章