HDU 1496 Equations(hash)

Equations

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6652    Accepted Submission(s): 2695


Problem Description
Consider equations having the following form: 

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.
 

Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
 

Output
For each test case, output a single line containing the number of the solutions.
 

Sample Input
1 2 3 -4 1 1 1 1
 

Sample Output
39088 0
 

Author
LL
 

Source
 

Recommend
LL
 

題解:雙向枚舉,hash。

#include <cstdio>
#include <cstring>
#include <iostream>
#include <vector>
#define M 1000005

using namespace std;

vector<int>z,f;
int a,b,c,d;
int h[2*M];

int H(int x) {
    return x+1000000;
}

void solve() {
    if(a>0&&b>0&&c>0&&d>0
            ||(a<0&&b<0&&d<0&&c<0)) {
        puts("0");
        return;
    }
    memset(h,0,sizeof h);
    for(int i=1; i<=100; i++) {
        for(int j=1; j<=100; j++) {
            h[H(a*i*i+b*j*j)]++;
        }
    }
    int ans=0;
    for(int i=1; i<=100; i++) {
        for(int j=1; j<=100; j++) {
            int s=H(-i*i*c-d*j*j);
            ans+=h[s];
        }
    }
    printf("%d\n",ans*16);
}

int main() {
    while(~scanf("%d%d%d%d",&a,&b,&c,&d)) {
        solve();
    }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章