Reward(HDOJ-2647)

Problem Description

Dandelion’s uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a’s reward should more than b’s.Dandelion’s unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work’s reward will be at least 888 , because it’s a lucky number.

Input

One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a’s reward should be more than b’s.

Output

For every case ,print the least money dandelion ‘s uncle needs to distribute .If it’s impossible to fulfill all the works’ demands ,print -1.

Sample Input

2 1
1 2
2 2
1 2
2 1

Sample Output

1777
-1

題意:

給出n個工人的m條工資對比關係,工人的最低工資是888。

思路:

很明顯,只要拓撲排序一遍,得出每個工人的工資高低關係,然後高的人比低的人高1元,用res記錄每個人的工資,如果最後統計出的人數小於n說明無法排序,輸出-1。

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cstdlib>
#include <map>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <list>
#include <cmath>
#include <algorithm>
#define MST(a, b) memset(a, b, sizeof(a))
using namespace std;
typedef long long ll;
const int MAXN = 10000 + 10;
int n, m;
vector <int> g[MAXN];
int res[MAXN], dgree[MAXN], ans;
void init() {
    for (int i = 1; i <= n; i++) g[i].clear();
    MST(res, 0);
    MST(dgree, 0);
    ans = 0;
}
bool topo() {
    queue <int> q;
    int pos = 0;
    for (int i = 1; i <= n; i++)
        if (!dgree[i]) {
            q.push(i);
            res[i] = 888;
            pos++;
        }
    while (!q.empty()) {
        int u = q.front();
        q.pop();
        ans += res[u];
        for (int i = 0; i < g[u].size(); i++) {
            if (--dgree[g[u][i]] == 0) {
                res[g[u][i]] = res[u] + 1;
                pos++;
                q.push(g[u][i]);
            }
        }
    }
    if (pos < n) return false;
    return true;
}
int main() {
    ios::sync_with_stdio(false); cin.tie(0); cout.tie(0);
    while (cin >> n >> m) {
        init();
        while (m--) {
            int x, y;
            cin >> x >> y;
            g[y].push_back(x);
            dgree[x]++;
        }
        if (!topo()) cout << "-1" << endl;
        else cout << ans << endl;
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章