POJ1573--Robot Motion(模擬)

Description

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are
這裏寫圖片描述
N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)
For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.
Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.
You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word “step” is always immediately followed by “(s)” whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

題意

四個方向走
判斷能不能走出來
能輸出步數
不能的話,走幾步開始循環,循環的步數是多少

思路

水。

代碼

#include <cstring>
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <map>
#include <set>
using namespace std;
const int maxn = 110;
int G[maxn][maxn];
int book[maxn][maxn];
int n, m, t;
map<char,int>mp;
int dir[4][2] = {{-1,0},{0,-1},{1,0},{0,1}};
void init()
{
    mp['N'] = 0;
    mp['W'] = 1;
    mp['S'] = 2;
    mp['E'] = 3;
}
void gao()
{
    int sum1 = 0, sum2 = 0;
    int x = 1, y = t;
    while(1)
    {
        if(x <= 0 || x > n || y <= 0 || y > m)
            break;
        if(book[x][y] == 0)
            { sum1 ++; book[x][y] = 1; }
        else if(book[x][y] == 1)
            { sum2 ++; book[x][y] = 2; }
        else if(book[x][y] == 2)
            break;
        int tx = x, ty = y;
        x = tx + dir[G[tx][ty]][0]; 
        y = ty + dir[G[tx][ty]][1];
    }
    if(sum2 == 0)
        printf("%d step(s) to exit\n", sum1);
    else
        printf("%d step(s) before a loop of %d step(s)\n", sum1-sum2, sum2);
}
int main()
{
    init();
    while( cin >> n >> m >> t && n|m|t)
    {
        char a;
        memset(G, 0, sizeof(G));
        memset(book, 0, sizeof(book));
        for(int i = 1; i <= n; i ++)
            for(int j = 1; j <= m; j ++)
            {
                cin >> a;
                G[i][j] = mp[a];
            }
        gao();
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章