POJ1753--Flip Game(枚舉)

Do more with less

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it’s black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
Choose any one of the 16 pieces.
Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).
Consider the following position as an example:
這裏寫圖片描述
bwbw
wwww
bbwb
bwwb
Here “b” denotes pieces lying their black side up and “w” denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:
bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters “w” or “b” each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it’s impossible to achieve the goal, then write the word “Impossible” (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

思路

只有正反兩面,可以用0,1表示,就可以把一行的狀態壓縮到一個char型變量裏面
當確定了第一行的狀態之後,第二行的狀態有第一行確定
枚舉第一行的狀態的所有情況
最後一行符合要求的時候,記錄一個翻的次數
比較得到最小次數
有兩種狀態符合要求,全黑和全白

代碼

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
char piece[4][4];
char oripiece[4];
char pieces[4];
char result[4];
int ans = 0;
int mintime = 1 << 30;
void SetBit(char &c,int i,char v)
{
    int m = 0;
    if(v == 'w')
        m = 1;
    if(m)
        c |= (1 << i);
    else
        c &= ~(1 << i);
}
int GetBit(char c, int i)
{
    return (c >> i) & 1;
}
void FlipBit(char &c,int i)
{
    c ^= (1 << i);
}
using namespace std;

int main()
{
    int x = 0;
    int y = 0;
    for(int i = 0; i < 4; i ++)
        for(int j = 0; j < 4; j ++)
        {
            cin >> piece[i][j];
            SetBit(oripiece[i],j,piece[i][j]);
            if(piece[i][j] == 'b') x ++;
            else if(piece[i][j] == 'w') y ++;
        }
    if(x == 16 || y == 16)
    {
        cout << "0" << endl;
        return 0;
    }
    for(int k = 0; k < 16; k ++)
    {
        ans = 0;
        int switchs = k;
        memcpy(pieces,oripiece,sizeof(oripiece));
        for(int i = 0; i < 4; i ++)
        {
            result[i] = switchs;
            for(int j = 0;j < 4; j ++)
            {
                if(GetBit(result[i],j))
                {
                    ans ++;
                    FlipBit(pieces[i],j);
                    if(j > 0)
                        FlipBit(pieces[i],j-1);
                    if(j < 3)
                        FlipBit(pieces[i],j+1);
                    if(i < 3)
                        FlipBit(pieces[i+1],j);
                }
            }
            switchs = pieces[i];
        }
        if(pieces[3] == 0)
            mintime = min(mintime,ans);
    }
    for(int k = 0; k < 16; k ++)
    {
        ans = 0;
        int switchs = k;
        memcpy(pieces,oripiece,sizeof(oripiece));
        for(int i = 0; i < 4; i ++)
        {
            result[i] = switchs;
            for(int j = 0;j < 4; j ++)
            {
                if(GetBit(result[i],j))
                {
                    ans ++;
                    FlipBit(pieces[i],j);
                    if(j > 0)
                        FlipBit(pieces[i],j-1);
                    if(j < 3)
                        FlipBit(pieces[i],j+1);
                    if(i < 3)
                        FlipBit(pieces[i+1],j);
                }
            }
            switchs = ~pieces[i];
        }
        if(pieces[3] == 15)
            mintime = min(mintime,ans);
    }
    if(mintime != 1 << 30)
        cout << mintime << endl;
    else
        cout << "Impossible" << endl;
    return 0;
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章