POJ2060-Taxi Cab Scheme (最小路徑覆蓋)

Running a taxi station is not all that simple. Apart from the obvious demand for a centralised coordination of the cabs in order to pick up the customers calling to get a cab as soon as possible, there is also a need to schedule all the taxi rides which have been booked in advance. Given a list of all booked taxi rides for the next day, you want to minimise the number of cabs needed to carry out all of the rides.

For the sake of simplicity, we model a city as a rectangular grid. An address in the city is denoted by two integers: the street and avenue number. The time needed to get from the address a, b to c, d by taxi is |a - c| + |b - d| minutes. A cab may carry out a booked ride if it is its first ride of the day, or if it can get to the source address of the new ride from its latest, at least one minute before the new ride’s scheduled departure. Note that some rides may end after midnight.
Input
On the first line of the input is a single positive integer N, telling the number of test scenarios to follow. Each scenario begins with a line containing an integer M, 0 < M < 500, being the number of booked taxi rides. The following M lines contain the rides. Each ride is described by a departure time on the format hh:mm (ranging from 00:00 to 23:59), two integers a b that are the coordinates of the source address and two integers c d that are the coordinates of the destination address. All coordinates are at least 0 and strictly smaller than 200. The booked rides in each scenario are sorted in order of increasing departure time.
Output
For each scenario, output one line containing the minimum number of cabs required to carry out all the booked taxi rides.
Sample Input
2
2
08:00 10 11 9 16
08:07 9 16 10 11
2
08:00 10 11 9 16
08:06 9 16 10 11
Sample Output
1
2
題目:POJ2060
題意:給你一些出租車預定消息,包括開始時間,起點座標以及終點座標,如果一輛出租車在處理完當前預定後,能夠提前1分鐘以上到達下一個預定訂單的起點,那麼出租車可以接着進行下個訂單,問處理完所有訂單最少需要多少出租車。
思路:要求最少的出租車數目,那麼每輛被派出的出租車要儘可能完成多的訂單。
那麼不妨假設,開始時我們對於每個訂單都派出一輛出租車,我們就需要n輛出租,但是爲了節約,如果我們讓一輛出租車在完成了一個訂單以後,繼續去找下一個可以執行的訂單,這樣,我們每匹配到一個訂單,出租車的數量就會減1
題目就被我們轉化成了一個二分匹配問題,我們只需要對每個訂單標號,存在匹配關係的訂單進行建邊,然後二分匹配,答案就是:訂單數-最大匹配數
AC代碼:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
#define met(s,k) memset(s,k,sizeof s)
#define scan(a) scanf("%d",&a)
#define scanl(a) scanf("%lld",&a)
#define scann(a,b) scanf("%d%d",&a,&b)
#define scannl(a,b) scanf("%lld%lld",&a,&b)
#define scannn(a,b,c) scanf("%d%d%d",&a,&b,&c)
#define prin(a) printf("%d\n",a)
#define prinl(a) printf("%lld\n",a)
using namespace std;
typedef long long ll;
const int maxn=505;
int vis[2*maxn],match[2*maxn],p[maxn],num,n,m;
struct plan
{
    int t,sx,sy,ex,ey;
    friend bool operator< (plan a,plan b)
    {
        return a.t<b.t;
    }
}pl[maxn];
struct edge
{
    int st,en,next;
}e[maxn*maxn];
void init()
{
    met(p,-1);
    num=0;
}
void add(int st,int en)
{
    e[num].st=st;
    e[num].en=en;
    e[num].next=p[st];
    p[st]=num++;
}
int matched(int u)
{
    for(int i=p[u]; i!=-1; i=e[i].next)
    {
        int v=e[i].en;
        if(!vis[v])
        {
            vis[v]=1;
            if(!match[v]||matched(match[v]))
            {
                match[v]=u;
                match[u]=v;
                return 1;
            }
        }
    }
    return 0;
}
int hungarian()//匈牙利算法求最大匹配
{
    int ans=0;
    met(match,0);
    for(int i=1; i<=m; i++)
    {
        if(!match[i])
        {
            met(vis,0);
            if(matched(i))
            {
                ans++;
            }
        }
    }
    return ans;
}
int main()
{
    scan(n);
    while(n--)
    {
        init();
        scan(m);
        for(int i=1;i<=m;i++)
        {
            int a,b;
            scanf("%d:%d%d%d%d%d",&a,&b,&pl[i].sx,&pl[i].sy,&pl[i].ex,&pl[i].ey);
            pl[i].t=a*60+b;
        }
        sort(pl+1,pl+1+m);//對訂單按時間排序,時間晚的肯定無法和時間早的進行匹配
        for(int i=1;i<=m;i++)
        {
            for(int j=1;j<i;j++)
            {
                if(pl[i].t-1-(abs(pl[j].ex-pl[j].sx)+abs(pl[j].ey-pl[j].sy)+(abs(pl[i].sx-pl[j].ex)+abs(pl[i].sy-pl[j].ey)))>=pl[j].t)add(i,j+maxn);//滿足條件的訂單建邊,注意虛擬點
            }
        }
        prin(m-hungarian());
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章