hdu1002

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 264997    Accepted Submission(s): 51287


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
2 1 2 112233445566778899 998877665544332211
 

Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

#include<stdio.h>
#include<string.h>
int main()
{
    int k,m,c,i,w,d[1001]={0},h,n,j=1;
    char a[1001],b[1001],e,f;//由於數字過長,不能用int,只能用char記錄。
    scanf("%d",&n);
    while(n--)
  {
    scanf("%s %s",a,b);
   k=strlen(a);m=strlen(b);
   c=0;//用來逢10進位
   if(k>m)w=k;else w=m;
   h=w;
   while(k>=0||m>=0)
  {
    if(k>=1){e=a[k-1];}else e='0';
    if(m>=1){f=b[m-1];}else f='0';
    if((e+f-'0'-'0'+c)>=10)//將char轉成int,判斷其是否需要進位
   {
     d[h]=e+f-'0'-'0'+c-10;
     c=1;
   }
    else
  {
    d[h]=e+f-'0'-'0'+c;
    c=0;
  }
   k--;m--;h--;
 }
  if(d[0]==0)
 {
   printf("Case %d:\n",j++);
   printf("%s + %s = ",a,b);
   for(i=1;i<=w;i++)
  {
    printf("%d",d[i]);
  }
   if(n!=0) printf("\n\n");//注意兩個例子間有空行,最後一個沒有
   else printf("\n");
 }
  else
 {
   printf("Case %d:\n",j++);
   printf("%s + %s = ",a,b);
   for(i=0;i<=w;i++)
  {
    printf("%d",d[i]);
  }
   if(n!=0) printf("\n\n");
   else printf("\n");
 }
 }
return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章