hdu 5036 Explosion 2014 ACM/ICPC Asia Regional Beijing Online



Explosion

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 305    Accepted Submission(s): 86


Problem Description
Everyone knows Matt enjoys playing games very much. Now, he is playing such a game. There are N rooms, each with one door. There are some keys(could be none) in each room corresponding to some doors among these N doors. Every key can open only one door. Matt has some bombs, each of which can destroy a door. He will uniformly choose a door that can not be opened with the keys in his hand to destroy when there are no doors that can be opened with keys in his hand. Now, he wants to ask you, what is the expected number of bombs he will use to open or destroy all the doors. Rooms are numbered from 1 to N.
 

Input
The first line of the input contains an integer T, denoting the number of testcases. Then T test cases follow.

In the first line of each test case, there is an integer N (N<=1000) indicating the number of rooms. 

The following N lines corresponde to the rooms from 1 to N. Each line begins with an integer k (0<=k<=N) indicating the number of keys behind the door. Then k integers follow corresponding to the rooms these keys can open.
 

Output
For each test case, output one line "Case #x: y", where x is the case number (starting from 1), y is the answer which should be rounded to 5 decimal places.
 

Sample Input
2 3 1 2 1 3 1 1 3 0 0 0
 

Sample Output
Case #1: 1.00000 Case #2: 3.00000
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:  5041 5040 5039 5038 5037 
 

题意:每个房间都有钥匙,钥匙可以打开房间的门,没有钥匙的时候只能用炸弹炸门,求所需炸弹的期望。

思路:每个房间需要的炸弹期望为1/s,s为联通这个房间的房间数,最后求和就是答案。

这题让我认识了bitset,很好用的数据结构。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <bitset>
using namespace std;
const int inf=0x3f3f3f3f;
const int N=1005;
int t,n,cas=1,a,k;
bitset<N> edge[N];
void init(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        edge[i].reset();
        edge[i][i]=1;
    }
    for(int i=1;i<=n;i++){
        scanf("%d",&k);
        while(k--){
            scanf("%d",&a);
            edge[i][a]=1;
        }
    }
}
void solve(){
    init();
    for(int i=1;i<=n;i++){
        for(int j=1;j<=n;j++){
            if(edge[j][i])edge[j]|=edge[i];
        }
    }
    double ans=0;
    for(int i=1;i<=n;i++){
        int sum=0;
        for(int j=1;j<=n;j++){
            if(edge[j][i])sum++;
        }
        ans+=1.0/sum;
    }
    printf("Case #%d: %.5lf\n",cas++,ans);
}
int main()
{
    scanf("%d",&t);
    while(t--)solve();
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章