hdu 5045 Contest dp+狀態壓縮 2014 ACM/ICPC Asia Regional Shanghai Online

Contest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 36    Accepted Submission(s): 9


Problem Description
In the ACM International Collegiate Programming Contest, each team consist of three students. And the teams are given 5 hours to solve between 8 and 12 programming problems. 

On Mars, there is programming contest, too. Each team consist of N students. The teams are given M hours to solve M programming problems. Each team can use only one computer, but they can’t cooperate to solve a problem. At the beginning of the ith hour, they will get the ith programming problem. They must choose a student to solve this problem and others go out to have a rest. The chosen student will spend an hour time to program this problem. At the end of this hour, he must submit his program. This program is then run on test data and can’t modify any more. 

Now, you have to help a team to find a strategy to maximize the expected number of correctly solved problems. 

For each problem, each student has a certain probability that correct solve. If the ith student solve the jth problem, the probability of correct solve is Pij .

At any time, the different between any two students’ programming time is not more than 1 hour. For example, if there are 3 students and there are 5 problems. The strategy {1,2,3,1,2}, {1,3,2,2,3} or {2,1,3,3,1} are all legal. But {1,1,3,2,3},{3,1,3,1,2} and {1,2,3,1,1} are all illegal. 

You should find a strategy to maximize the expected number of correctly solved problems, if you have know all probability
 

Input
The first line of the input is T (1 ≤ T ≤ 20), which stands for the number of test cases you need to solve.

The first line of each case contains two integers N ,M (1 ≤ N ≤ 10,1 ≤ M ≤ 1000),denoting the number of students and programming problem, respectively.

The next N lines, each lines contains M real numbers between 0 and 1 , the jth number in the ith line is Pij .
 

Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then a single real number means the maximal expected number of correctly solved problems if this team follow the best strategy, to five digits after the decimal point. Look at the output for sample input for details.
 

Sample Input
1 2 3 0.6 0.3 0.4 0.3 0.7 0.9
 

Sample Output
Case #1: 2.20000
 

Source
 

Recommend
hujie

題意:n個學生,m個問題 ,每個人答對每個問題的概率不同,但所有人回答問題的次數差不能大於1,求最大答對期望。

思路:這題其實跟期望關係不大,由於n<=10,可以考慮狀態壓縮dp,dp[i][j]表示第i個問題,狀態爲j時的最大期望。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
using namespace std;
const int inf=0x3f3f3f3f;
double a[15][1050];
double dp[1050][1<<10];
int n,m,t,x,y,cas=1;
void init(){
    memset(dp,-inf,sizeof(dp));
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
            scanf("%lf",&a[i][j]);
}
void solve(){
    dp[0][0]=0;
    for(int i=1;i<=m;i++){
        for(int j=0;j<(1<<n);j++){
            if(dp[i][j]==-inf)continue;
            int q=j;
            if(q==(1<<n)-1)q=0;
            for(int k=0;k<n;k++){
                int p=1<<k;
                if(q&p)continue;
                dp[i][q|p]=max(dp[i][q|p],dp[i-1][j]+a[k+1][i]);
            }
        }
    }
    double ans=0;
    for(int i=0;i<1<<n;i++){
        ans=max(ans,dp[m][i]);
    }
    printf("Case #%d: ",cas++);
    printf("%.5f\n",ans);
}
int main()
{
    scanf("%d",&t);
    while(t--){
        init();
        solve();
    }
    return 0;
}

 


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章