hdu 3415 Max Sum of Max-K-sub-sequence dp+單調隊列

Max Sum of Max-K-sub-sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6005    Accepted Submission(s): 2190


Problem Description
Given a circle sequence A[1],A[2],A[3]......A[n]. Circle sequence means the left neighbour of A[1] is A[n] , and the right neighbour of A[n] is A[1].
Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. 
Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the minimum start position, if still more than one , output the minimum length of them.
 

Sample Input
4 6 3 6 -1 2 -6 5 -5 6 4 6 -1 2 -6 5 -5 6 3 -1 2 -6 5 -5 6 6 6 -1 -1 -1 -1 -1 -1
 

Sample Output
7 1 3 7 1 3 7 6 2 -1 1 1
 

Author
shǎ崽@HDU
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  3423 3417 3418 3419 3421 
 


題意:一個環序列,首尾相連。求長度小於k的一段序列,保證其和最大的同時,儘量靠前,儘量短

思路:把序列複製模擬環,用sum數組存前i項和,通過枚舉求dp[i]=sum[i]-sum[j](i-j<=k)則爲最大和。

但暴力枚舉必定超時,在此採用優先隊維護當前儘量小的sum,然後比較一遍直接求就可以了,第一次做單調隊列1遍a。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int N=100005;
const int inf=0x3f3f3f3f;
int ans,front,back;
struct node
{
    int x,v;
}deq[2*N];
int sum[2*N],a[2*N];
int main()
{
    int n,m,t,sta,end;
    scanf("%d",&t);
    while(t--){
        ans=-inf;
        scanf("%d%d",&n,&m);
        memset(sum,0,sizeof(sum));
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
            a[i+n]=a[i];
        }
        front=back=0;
        for(int i=1;i<=n*2;i++)
            sum[i]=a[i]+sum[i-1];
        for(int i=0;i<=n*2;i++){
            if(front<back){
                while(i-deq[front].x>m)front++;
                if(ans<sum[i]-deq[front].v){
                    ans=sum[i]-deq[front].v;
                    sta=deq[front].x+1;
                    sta=sta>n?sta-n:sta;
                    end=i>n?i-n:i;
                }
            }
            while(front<back&&sum[i]<deq[back-1].v)back--;
            deq[back].v=sum[i];
            deq[back++].x=i;
        }
        printf("%d %d %d\n",ans,sta,end);
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章