3976. Change

After Shawn sees the following picture, he decides to give up his career in IT and turn to sell fruits. Since Shawn is a lazy guy, he doesn’t like to do any extra work. When he starts selling fruits, he finds that he always needs to take changes for customers. He wants you to write a program to give the least number of changes. Shawn is also a strange guy, because he takes changes by 6,5,3,1.

Input

The first line of input is an integer T which indicates the sum of test case. Each of the following T lines contains an integer n(1≤n≤105), which is the total money Shawn need to give to the customer.

Output

For each test case, output "Case i: Result" in one line where i is the case number and Result is the least number of changes Shawn need to give customer.

Sample Input

3
4
10
19

Sample output

	
Case 1: 2
Case 2: 2
Case 3: 4

Hint

Case 1: 4=3+1
Case 2: 10=5+5
Case 3: 19=6+6+6+1

找零錢問題,沒有用動態規劃,而是找了規律


#include<iostream>
using namespace std;
int a[12]={1,2,1,2,1,1,2,2,2,2,2,2};
int main()
{
    int T,N;
    cin>>T;
    for(int i=1;i<=T;++i)
    {
        int min=0;
        cin>>N;
        while(N>12)
        {
            ++min;
            N-=6;
        }
        if(N>0)
			min=min+a[N-1];
        cout<<"Case "<<i<<": "<<min<<endl; 
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章