杭電 1005

遞歸切記:

1.如果遞歸的次數大於100次,都很浪費時間,故應該考慮有沒有什麼規律;

2.遞歸時應該考慮循環節的情況。

對於此題,應當這麼看:

由於最後的結果是模7的,故f[n]可能的值只有7個,0~6,由於f[n]是由f[n-1]和f[n-2]決定,故最大7*7=49次一個循環,只要找到兩個連續的1出現,則可以確定爲一次循環開始。


Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 104494    Accepted Submission(s): 25339


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
1 1 3 1 2 10 0 0 0
 

Sample Output
2 5
#include<iostream>
using namespace std;
int main(){
	int a,b;
	int n,f[50];
	while(scanf("%d%d%d",&a,&b,&n)&&a&&b&&n){
		int i,j;
		f[1]=1;
		f[2]=1;
		if(n<50){
			for( i=3;i<=n;i++){
			f[i]=(a*f[i-1]+b*f[i-2])%7;
			}
			cout<<f[n]<<endl;
		}
		else{
			for( i=3;i<50;i++){
				f[i]=(a*f[i-1]+b*f[i-2])%7;
				if(f[i]==1&&f[i-1]==1)
					break;
			}
			j=n%(i-2);
			if(j==0)
				cout<<f[i-2]<<endl;
			else
			cout<<f[j]<<endl;
		}
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章