PAT甲級 1109. Group Photo (25)

Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

  • The number of people in each row must be N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;
  • All the people in the rear row must be no shorter than anyone standing in the front rows;
  • In each row, the tallest one stands at the central position (which is defined to be the position (m/2+1), where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);
  • In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);
  • When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

Now given the information of a group of people, you are supposed to write a program to output their formation.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers N (<=10000), the total number of people, and K (<=10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).

Output Specification:

For each case, print the formation -- that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

Sample Input:
10 3
Tom 188
Mike 170
Eva 168
Tim 160
Joe 190
Ann 168
Bob 175
Nick 186
Amy 160
John 159
Sample Output:
Bob Tom Joe Nick
Ann Mike Eva
Tim Amy John


模擬水題,讀懂題意就可以解。另外爲了方便排序,用了string來處理字符串。


#include <cstdio>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <cstdlib>
#include <climits>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

#define ll long long
const int MAXN = 10000 + 5;
const int MAXM = 100000 + 5;
const int INF = 0x7f7f7f7f;
template <class XSD> inline XSD f_min(XSD a, XSD b) { if (a > b) a = b; return a; }
template <class XSD> inline XSD f_max(XSD a, XSD b) { if (a < b) a = b; return a; }
int n, m;
struct NODE{
    int height;
    string name;
}node[MAXN], ans[MAXN];
bool cmp(NODE x, NODE y){
    if(x.height==y.height) return x.name<y.name;
    return x.height>y.height;
}
void Getdata(){
    for(int i=0; i<n; i++) 
        cin>>node[i].name>>node[i].height;
}
void Solve(){
    sort(node, node+n, cmp);
    int ave = int(n/m);
    int last= ave+n%m;
    int cnt=0, k=int(last/2)+1;
    ans[k]=node[cnt++];
    for(int i=1; i<=last/2; i++){
        if(last%2) ans[k-i]=node[cnt++], ans[k+i]=node[cnt++];
        else{
            ans[k-i]=node[cnt++];
            if(i!=(last/2)) ans[k+i]=node[cnt++];
        }
    }
    for(int i=1; i<=last; i++){
        cout<<ans[i].name;
        if(i<last) cout<<' ';
        else cout<<'\n';
    }
    m--;
    while(m--){
        k=int(ave/2)+1;
        ans[k]=node[cnt++];
        for(int i=1; i<=int(ave/2); i++){
            if(ave%2) ans[k-i]=node[cnt++], ans[k+i]=node[cnt++];
            else{
                ans[k-i]=node[cnt++];
                if(i!=int(ave/2)) ans[k+i]=node[cnt++];
            }
        }
        for(int i=1; i<=ave; i++){
            cout<<ans[i].name;
            if(i<ave) cout<<' ';
            else cout<<'\n';
        }
    }
}
int main(){
    while(~scanf("%d%d", &n, &m)){
        Getdata();
        Solve();
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章