1079. Total Sales of Supply Chain (25)

題目鏈接:http://www.patest.cn/contests/pat-a-practise/1079
題目:

A supply chain is a network of retailers(零售商), distributors(經銷商), and suppliers(供應商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] ... ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.

Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3
Sample Output:
42.4

分析:

AC代碼:
#include<stdio.h> 
#include<iostream> 
#include<vector> 
using namespace std; 

struct Node{ 
 vector<int>next; 
 int level; 
 int quatity; 
}; 
vector<int>V_ans; 
void calcLevel(Node* start_add, int idx, int cur_level){ 
 start_add[idx].level = cur_level; 
 if (start_add[idx].next.size() != 0){ 
  int child_count = start_add[idx].next.size(); 
  for (int i = 0; i < child_count; i++){ 
   calcLevel(start_add, start_add[idx].next[i], cur_level + 1); 
  } 
 } 
} 
int main(void){ 
 freopen("F://Temp/input.txt", "r", stdin); 
 int N; 
 double P,r; 
 cin >> N >> P >> r; 
 Node *buf = new Node[N]; 
 for (int i = 0; i < N; i++){ 
  int count; 
  cin >> count; 
  if (count == 0){ 
   V_ans.push_back(i); 
   cin >> buf[i].quatity; 
  } 
  else{ 
   for (int j = 0; j < count; j++){ 
    int child; 
    cin >> child; 
    buf[i].next.push_back(child); 
   } 
  } 
 }//for 
 calcLevel(buf ,0 , 0); 
 int max_level = -1; 
 for (int i = 0; i < N; i++){ 
  if (buf[i].level > max_level)max_level = buf[i].level; 
 } 
 double *price = new double[max_level + 1]; 
 price[0] = P; 
 for (int i = 1; i <= max_level; i++){ 
  price[i] = price[i - 1] * (1 + r / 100); 
 } 
 double ans = 0.0; 
 for (int i = 0; i < V_ans.size(); i++){ 
  ans += buf[V_ans[i]].quatity*price[buf[V_ans[i]].level]; 
 } 
 printf("%.1f\n", ans); 
 return 0; 
}


截圖:

——Apie陳小旭
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章