1094. The Largest Generation (25)

題目鏈接:http://www.patest.cn/contests/pat-a-practise/1094
題目:

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4

分析:
vector<int>...[100]來保存父節點和子節點即可,然後通過一次循環來找出最長的同輩數目
AC代碼:
#include<cstdio>
#include<iostream>
#include<vector>
#include<algorithm>
#include<queue>
#include<stack>
#include<string>
#include<string.h>
using namespace std;
int main(){
 freopen("F://Temp/input.txt", "r", stdin);
 int n, m;
 cin >> n >> m;
 vector<int> vec_arr[100];
 //vector<int> *vec_arr = new vector<int>[n+1];//*Point!!這個+1不能忘啊!
 while (m--){
  int parent,count;
  cin >> parent >> count;
  while (count--){
   int child;
   cin >> child;
   vec_arr[parent].push_back(child);
  }
 }
 vector<int>V1;
 vector<int>V2;
 const int ROOT = 1;
 V1.push_back(ROOT);
 int max = 1, max_level = 1, cur_level = 1;
 while (true){
  ++cur_level;
  if (V1.size() == 0)break;
  for (int i = 0; i < V1.size(); ++i){
   for (int j = 0; j < vec_arr[V1[i]].size(); ++j){
    V2.push_back(vec_arr[V1[i]][j]);
   }
  }
  if (V2.size() > max){
   max = V2.size();
   max_level = cur_level;
  }
  V1 = V2;
  V2.clear();
 }
 cout << max << " " << max_level << endl;
 //delete []vec_arr;
 return 0;
}


截圖:

——Apie陳小旭
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章