1086. Tree Traversals Again (25)

題目鏈接:http://www.patest.cn/contests/pat-a-practise/1086
題目:

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1

分析:
思路:構建一個stack,其中其top就是當前節點,後添加的節點是其孩子,如果左孩子非空就添加到右孩子。
AC代碼:
#include<cstdio>
#include<iostream>
#include<stack>
#include<string>
using namespace std;
struct Node{
 int data;
 Node* lchild;
 Node* rchild;
 Node(int num):data(num),lchild(NULL),rchild(NULL){}
 Node():lchild(NULL),rchild(NULL){}//不要忘了寫上默認構造函數,否則孩子不爲空,判斷會有誤
};
Node* createTree(int nn){
 stack<Node*>Node_Stack;
 Node* ret = new Node();
 string str_tmp;
 cin >> str_tmp;
 int i_tmp;
 cin >> i_tmp;
 ret->data = i_tmp;//先讀取第一個元素
 Node* curNode = ret;
 Node_Stack.push(ret);
 while (--nn){//因爲已經少一個了,所以--nn
  string type;
  cin >> type;
  if (type == "Push"){
   int num_push;
   cin >> num_push;
   Node* newNode = new Node(num_push);
   if (curNode->lchild == NULL)
    curNode->lchild = newNode;
   else
    curNode->rchild = newNode;
   Node_Stack.push(newNode);
   curNode = newNode;
  }
  else if (type == "Pop"){
   curNode = Node_Stack.top(); //*特別注意當前節點是pop出來的節點
   Node_Stack.pop();
  }
 }
 return ret;
}
void postOrder(Node* root){//後續遍歷輸出
 if (root->lchild != NULL)postOrder(root->lchild);
 if (root->rchild != NULL)postOrder(root->rchild);
 static bool firstFlag = true;//設置標籤位,看是否是第一次輸出,爲了最後的空格格式化,注意這裏需要static
 if (firstFlag){
  cout << root->data;
  firstFlag = false;
 }
 else
  cout << " " << root->data;
}
int main(){
 freopen("F://Temp/input.txt", "r",stdin);
 int n;
 cin >> n;
 if (n == 0)return 0;//如果沒有輸入元素,則不用輸出,直接返回
 Node* root = createTree(2*n);//有2n組數據輸入
 postOrder(root);
 return 0;
}


截圖:

——Apie陳小旭
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章