The Balance(數論)

Description

Ms. Iyo Kiffa-Australis has a balance and only two kinds of weights to measure a dose of medicine. For example, to measure 200mg of aspirin using 300mg weights and 700mg weights, she can put one 700mg weight on the side of the medicine and three 300mg weights on the opposite side (Figure 1). Although she could put four 300mg weights on the medicine side and two 700mg weights on the other (Figure 2), she would not choose this solution because it is less convenient to use more weights. 
You are asked to help her by calculating how many weights are required. 

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers a, b, and d separated by a space. The following relations hold: a != b, a <= 10000, b <= 10000, and d <= 50000. You may assume that it is possible to measure d mg using a combination of a mg and b mg weights. In other words, you need not consider "no solution" cases. 
The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of lines, each corresponding to an input dataset (a, b, d). An output line should contain two nonnegative integers x and y separated by a space. They should satisfy the following three conditions. 
  • You can measure dmg using x many amg weights and y many bmg weights. 
  • The total number of weights (x + y) is the smallest among those pairs of nonnegative integers satisfying the previous condition. 
  • The total mass of weights (ax + by) is the smallest among those pairs of nonnegative integers satisfying the previous two conditions.

No extra characters (e.g. extra spaces) should appear in the output.

Sample Input

700 300 200
500 200 300
500 200 500
275 110 330
275 110 385
648 375 4002
3 1 10000
0 0 0

Sample Output

1 3
1 1
1 0
0 3
1 1
49 74
3333 1

解題思路

拓展歐幾里得求最小正解,比較難以理解的是求出一組解後,如何求最小正解的過程,此題再次再次求教了userluoxuan,在此鳴謝


AC代碼

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
using namespace std;
const int INF = 999999999;
int gcd(int a, int b)
{
    return b ? gcd(b, a % b) : a;
}
int extend_gcd (int a, int b, int &x, int &y)
{
    if(b == 0)
    {
        x = 1;
        y = 0;
        return a;
    }
    int r = extend_gcd(b, a % b, x, y);
    int temp = x;
    x = y;
    y = temp - a / b * y;
    return r;
}
int main()
{
    int a, b, n, d, x, y, min, min_x, min_y;
    while(scanf("%d%d%d", &a, &b, &n) && ( a || b || n) )
    {
        bool flag = false;
        min = INF;
        if(a < b)
        {
            swap(a, b);
            flag = true;                           //原方程等式爲a * x + b * y = n 

        }
        d = gcd(a, b);                             //求a,b的最大公約數,a,b化成互質的
        a /= d;
        b /= d;
        extend_gcd(a, b, x, y);                    //求出a * x + b * y = n / gcd(a , b)  的一組解         
        x *= n / d;                                //化成原方程的解
        y *= n / d;
        int t = y / a;                             //由通解公式有 y(n) = y - a * t ,令y(n) = 0,有 t = y / a,此t爲0點左右的
        for(int i = t - 1; i <= t + 1; i++)        //查找t左右兩解,尋找最小正解
        {
            int x_1 = x + b * i;
            int y_1 = y - a * i;
            if(abs(x_1) + abs(y_1) < min)
            {
                min = abs(x_1) + abs(y_1);
                min_x = abs(x_1);
                min_y = abs(y_1);
            }
        }
        if(flag)
            printf("%d %d\n", min_y, min_x);
        else
            printf("%d %d\n", min_x, min_y);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章