04-樹7. Search in a Binary Search Tree (25)


時間限制
100 ms
內存限制
65536 kB
代碼長度限制
8000 B
判題程序
Standard
作者
CHEN, Yue

To search a key in a binary search tree, we start from the root and move all the way down, choosing branches according to the comparison results of the keys. The searching path corresponds to a sequence of keys. For example, following {1, 4, 2, 3} we can find 3 from a binary search tree with 1 as its root. But {2, 4, 1, 3} is not such a path since 1 is in the right subtree of the root 2, which breaks the rule for a binary search tree. Now given a sequence of keys, you are supposed to tell whether or not it indeed correspnds to a searching path in a binary search tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (<=100) which are the total number of sequences, and the size of each sequence, respectively. Then N lines follow, each gives a sequence of keys. It is assumed that the keys are numbered from 1 to M.

Output Specification:

For each sequence, print in a line "YES" if the sequence does correspnd to a searching path in a binary search tree, or "NO" if not.

Sample Input:
3 4
1 4 2 3
2 4 1 3
3 2 4 1
Sample Output:
YES
NO
NO
#include <iostream>
#include <string.h>
#define N 101

using namespace std;

int main()
{
    int a[N],n,m,i,j,flag,k;
    cin>>n>>m;
    for(i=0;i<n;i++)
    {
        memset(a,-1,sizeof(N));
        for(j=0;j<m;j++)
            cin>>a[j];
        flag = a[0];
        bool result = true;
        for(j=1;j<m;j++)
        {

            if(flag<a[j])
            {
                for(k=j+1;k<m;k++)
                    if(flag > a[k])
                    {
                        result = false;
                        break;
                    }

            }else if(flag>a[j])
            {
                for(k=j+1;k<m;k++)
                    if(flag < a[k])
                    {
                        result = false;
                        break;
                    }
            }
            if(!result)
            {
                cout<<"NO\n";
                break;
            }else
                flag = a[j];
        }
        if(result)
            cout<<"YES\n";

    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章