A - stl 的 map

stl 的 map

題目描述

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you

Iutput

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink


思路:

題意:統計出各種顏色出現最多次數的那個;


代碼

#include<iostream>
#include<map>
#include<string>
using namespace std;

int main()
{
    map<string,int> balloon;
    int n;
    string a;
    while(cin >> n&& n!=0)
    {
        balloon.clear();
        while(n--)
        {
            cin >> a;
            balloon[a]++;
        }
        map<string,int>::iterator it;
        int max=-100;string maxcolor;
        for (it=balloon.begin();it!=balloon.end();it++)
        {
            if((*it).second>max)
            {
                max=(*it).second;
                maxcolor=(*it).first;
            }
        }
        cout<<maxcolor<<endl;
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章