R - Joseph

Joseph

題目描述

The Joseph’s problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, …, n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

Iutput

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input

3
4
0

Sample Output

5
30


思路:

給所有人編號,前一半好人後一半壞人,從第零個開始數,數的時候用取餘的方法確定在哪個位置,爲前一半則跳出,因爲好人不會出去,所以前一半標號永遠不變,判斷條件也因此不用改變,每次更新取餘的人數


代碼

#include<stdio.h> 
#include<string.h>
bool joseph(int k,int m)
{
    int bg=0,ed=k-1,tp;
    for(int n=2*k;n>k;--n)
    {
        tp=(m-1)%n;
        if(tp>=bg&&tp<=ed)
        {
            return 0;
        }
        bg=(bg-m%n+n)%n;ed=(ed-m%n+n)%n;
        //bg=((bg-m)%n+n)%n;ed=((ed-m)%n+n)%n;//同餘還是理解的不夠
    }
    return 1;
}
int main()
{
    int n,y[20]={0};
    for(int i=1;i<14;++i)
    {
        int j=i+1;
        while(1)
        {
            if(joseph(i,j))
            {
                y[i]=j;
                break; 
            }
            ++j;
        } 
    }

    while(scanf("%d",&n),n)
    {
        printf("%d\n",y[n]);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章