Z - A + B Problem II

A + B Problem II

題目描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Iutput

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


思路:

構造字符串數組保存兩個加數,然後利用棧結構來存儲每一位的的和,每一位的和包括兩個字符串相應位置字符值相加和低位的進位;


代碼

#include <cstdio>
#include <cstring>
#include <stack>
using namespace std;
int main()
{
    int t,i,num=1;
    scanf("%d",&t);

    while(t--){
        stack<int> st;
        char a[1005],b[1005];

        if(num>1)
            printf("\n");

        scanf("%s%s",a,b);

        int lena=strlen(a)-1;
        int lenb=strlen(b)-1;

        printf("Case %d:\n",num);
        for(i=0;i<=lena;i++){
            printf("%c",a[i]);
        }
        printf(" + ");
        for(i=0;i<=lenb;i++){
            printf("%c",b[i]);
        }
        printf(" = ");

        int s,c=0;
        while(lena>=0&&lenb>=0){
            s=(a[lena]-'0')+(b[lenb]-'0')+c;
            if(s>=10){
                s-=10;
                c=1;
            }
            else c=0;

            st.push(s);
            lena--;
            lenb--;

            if(lena==-1){
                for(i=lenb;i>=0;i--){
                    s=(b[i]-'0')+c;
                    if(s>=10){
                        s-=10;
                        c=1;
                    }
                    else c=0;

                    st.push(s);
                }
                if(c)
                    st.push(c);

                while(!st.empty()){
                    printf("%d",st.top());
                    st.pop();
                }
                printf("\n");
                break;

            }

            if(lenb==-1){
                for(i=lena;i>=0;i--){
                    s=(a[i]-'0')+c;
                    if(s>=10){
                        s-=10;
                        c=1;
                    }
                    else c=0;

                    st.push(s);
                }
                if(c)
                    st.push(c);

                while(!st.empty()){
                    printf("%d",st.top());
                    st.pop();
                }

                printf("\n");
                break;

            }

        }

        num++;
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章