K - next_permutation

next_permutation

題目描述

Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, “I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too.” Ignatius says confidently, “OK, at last, I will save the Princess.”

“Now I will show you the first problem.” feng5166 says, “Given a sequence of number 1 to N, we define that 1,2,3…N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it’s easy to see the second smallest sequence is 1,2,3…N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It’s easy, isn’t is? Hahahahaha……”
Can you help Ignatius to solve this problem?

Input

The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub’s demand. The input is terminated by the end of file.

Output

For each test case, you only have to output the sequence satisfied the BEelzebub’s demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.

Sample Input

6 4
11 8

Sample Output

1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10


思路:

題意:
找出由1、2、3、……、n-1、n構成的全排列中第m小的;
思路:直接使用stl庫中的函數next_permulation就行了,不用自己胡亂推導;


代碼

#include <stdio.h>
#include <algorithm>

using namespace std;
int main()
{
    int N,M;
    int arr[1005];
    while(scanf("%d%d",&N,&M)!=EOF){
        int i;
        for(i=0;i<N;i++)
            arr[i]=i+1;

        for(i=1;i<M;i++)
            if(next_permutation(arr,arr+N))
                continue;
        for(i=0;i<N-1;i++)
            printf("%d ",arr[i]);

        printf("%d\n",arr[N-1]);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章