I - 輾轉相除法求最大公約數

輾轉相除法求最大公約數

題目描述

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input

2
3 5 7 15
6 4 10296 936 1287 792 1

Sample Output

105
10296


思路:

這題題目有毛病,應該是用輾轉相除法求出最大公約數,然後再求出最小公倍數;【輾轉相除法


代碼

#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

int arr[1000];

bool cmp(int x,int y)
{
    return x<y;
}

int lcm(int x,int y)
{
    //x除數,y餘數
    int p,r,a,b;
    a=x;
    b=y;
    r=y%x;
    p=y/x;

    while(r)
    {
        x=r;
        y=(y-r)/p;
        p=y/x;
        r=y%x;
    }
    return (a/x)*b;
}

int main()
{
    int n,m,i;
    while(scanf("%d",&n)!=EOF)
    {
        while(n--)
        {
            memset(arr,0,sizeof(arr));

            scanf("%d",&m);
            for(i=0; i<m; i++)
            {
                scanf("%d",&arr[i]);
            }

            int temp=arr[0];

            for(i=1; i<m; i++)
            {
                if(arr[i]<temp) //維持大小順序
                {
                    int temp1=arr[i];
                    arr[i]=temp;
                    temp=temp1;
                }
                temp=lcm(temp,arr[i]);
            }
            printf("%d\n",temp);
        }
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章