POJ 3026 Borg Maze

Borg Maze
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12469   Accepted: 4083

Description

The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance. 

Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

Input

On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space `` '' stands for an open space, a hash mark ``#'' stands for an obstructing wall, the capital letter ``A'' stand for an alien, and the capital letter ``S'' stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the ``S''. At most 100 aliens are present in the maze, and everyone is reachable.

Output

For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

Sample Input

2
6 5
##### 
#A#A##
# # A#
#S  ##
##### 
7 7
#####  
#AAA###
#    A#
# S ###
#     #
#AAA###
#####  

Sample Output

8
11

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top


剛做的POJ,難度果然不一樣(雖然是初級的233暑假集訓的第一道ac題,這道題被列到了最小生成樹,要是事先用最小生成樹的話我估計根本想不到吧,很久沒有碰代碼了,最小生成樹差點不會敲了都,而且這道題難點其實並不在最小生成樹,關鍵是要找出A之間的距離,只要找出距離的話直接套用Prime就能做出來,而A之間的距離其實也很容易想到搜索,這種迷宮的兩點最短距離直接可以用廣搜,代碼如下

Source Code

Problem: 3026   User: 15110572012
Memory: 256K   Time: 688MS
Language: C++   Result: Accepted
  • Source Code
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <iostream>
    #define ll long long
    #define inf 99999999
    using namespace std;
    int m[100+5][100+5];
    int next[4][2]={{1,0},{0,1},{0,-1},{-1,0}};
    bool vis[50+5][50+5];
    struct A
    {
        int x, y;
    }A[100+5];
    struct node
    {
        int x, y;
        int step;
    }boy[100000000+5];
    int main()
    {
        int n;
        scanf("%d", &n);
        while(n--)
        {
            int x, y, ans=0, ex, ey;
            scanf("%d %d\n", &x, &y);
            char s[50+5][50+5];
            for(int i=0;i<y;i++)
                gets(s[i]);
            for(int i=0;i<y;i++)
                for(int j=0;j<x;j++)
            {
                if(s[i][j]=='A')
                {
                    A[ans].x=i;
                    A[ans++].y=j;
                }
                else if(s[i][j]=='S')
                {
                    ex=i;
                    ey=j;
                }
            }
            A[ans].x=ex;
            A[ans++].y=ey;
            for(int i=0;i<ans;i++)
                for(int j=0;j<ans;j++)
            {
                if(i==j) m[i][j]=0;
                else
                {
                    bool f=0;
                    memset(vis,0,sizeof(vis));
                    int head=0, tail=0;
                    boy[tail].x=A[i].x;
                    boy[tail].y=A[i].y;
                    boy[tail++].step=0;
                    vis[A[i].x][A[i].y]=1;
                    while(head<tail)
                    {
                        for(int i=0;i<4;i++)
                        {
                            int tx=boy[head].x;
                            int ty=boy[head].y;
                            tx+=next[i][0];
                            ty+=next[i][1];
                            if(tx>=0&&tx<x&&ty>=0&&ty<y&&!vis[tx][ty]&&s[tx][ty]!='#')
                            {
    //                            cout<<tx<<' '<<ty<<' '<<s[tx][ty]<<endl;
                                vis[tx][ty]=1;
                                boy[tail].x=tx;
                                boy[tail].y=ty;
                                boy[tail++].step=boy[head].step+1;
                            }
                            if(boy[tail-1].x==A[j].x&&boy[tail-1].y==A[j].y)
                            {
                                f=1;
                                break;
                            }
                        }
                        if(f) break;
                        head++;
                    }
                    if(f)
                      m[i][j]=boy[tail-1].step;
                    else m[i][j]=inf;
                }
            }
            int dis[1000+5];
            for(int i=0;i<ans;i++)
                dis[i]=m[0][i];
            bool vis[1000+5];
            memset(vis,0,sizeof(vis));
            vis[0]=1;
            int sum=0;
            for(int i=1;i<ans;i++)
            {
                int pos=-1, mi=inf;
                for(int j=0;j<ans;j++)
                if(dis[j]<mi&&!vis[j]) {pos=j;mi=dis[j];}
                if(pos==-1) break;
                sum+=mi;
                vis[pos]=1;
                for(int j=0;j<ans;j++)
                    if(!vis[j]&&dis[j]>m[pos][j])
                       dis[j]=m[pos][j];
            }
            printf("%d\n", sum);
        }
        return 0;
    }

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章