poj1386 Paly onWords

題目大意:給你很多單詞,讓你爲這些單詞排序,使這些單詞每個單詞首字母是上個單詞的尾字母。

分析:對於每一個單詞,我們只需要紀錄下它的首字母和尾字母即可,然後單詞接龍就變爲了我們熟知的歐拉路徑問題了。一個有向圖存在歐拉路徑,當且僅當該圖是連通的,且所有頂點的出度和入度度數之和爲0,或僅存在一個度數爲1的頂點和一個度數爲-1的頂點,其他頂點的度數爲0。

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. 

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door. 
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.
Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. 
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.". 
Sample Input
3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok
Sample Output
The door cannot be opened.
Ordering is possible.
The door cannot be opened.
#include<string.h>
#include<stdio.h>
#define INF 0x3f3f3f3f
int T,n;
char word[1010];
int od[26],id[26];
int bu[26],f[26];
struct node
{
    int u,v;
}edge[100010];
void init()      //初始化
{
    for(int i=0;i<26;i++)
        f[i]=-1;
}
int findd(int x)    //判斷兩個點是否同爲一個祖先
{
    int s;
    for(s=x;f[s]>=0;s=f[s])
        ;
    while(s!=x)
    {
        int tmp=f[x];
        f[x]=s;
        x=tmp;
    }
    return s;
}
void Union(int R1,int R2)  //合併子集
{
    int r1,r2;
    r1=findd(R1);
    r2=findd(R2);
    int tmp=f[r1]+f[r2];
    if(f[r1]>f[r2])
        {
            f[r1]=r2;
            f[r2]=tmp;
        }
        else
        {
            f[r2]=r1;
            f[r1]=tmp;
        }
}
int bconnect()   //判斷有向圖的基圖是否聯通
{
    int u,v,i;
    init();
    for(i=0;i<n;i++)
    {
        u=edge[i].u;
        v=edge[i].v;
        if(u!=v&&findd(u)!=findd(v))
            Union(u,v);
    }
    int first=-1;
    for(i=0;i<26;i++)
    {
        if(bu[i]==0)continue;
        if(first==-1)first=i;
        else if(findd(i)!=findd(first))break;
    }
    if(i<26)return 0;
    else return 1;
}
int main()
{
    int u,v,i,j;
    scanf("%d",&T);
    while(T--)
    {
        memset(od,0,sizeof(od));
        memset(id,0,sizeof(id));
        memset(bu,0,sizeof(bu));
        scanf("%d",&n);
        for(j=0;j<n;j++)
        {
            scanf("%s",word);
            u=word[0]-'a';v=word[strlen(word)-1]-'a';
            od[u]++;id[v]++;
            bu[u]=bu[v]=1;
            edge[j].u=u;edge[j].v=v;
        }
        int euler=1;
        int one=0;   //出度比入度多1 的個數
        int none=0;   //出度比入度少1的個數
        for(j=0;j<26;j++)
        {
            if(bu[j]==0)continue;
            if(od[j]-id[j]>=2||id[j]-od[j]>=2)
            {
                euler=0;break;
            }
            if(od[j]==0&&id[j]==0)
            {
                euler=0;break;
            }
            if(od[j]-id[j]==1)
            {
                one++;
                if(one>1)
                {
                    euler=0;break;
                }
            }
            if(id[j]-od[j]==1)
            {
                none++;
                if(none>1){euler=0;break;}
            }
        }
        if(one!=none)euler=0;
        if(!bconnect())euler=0;
        if(euler)printf("Ordering is possible.\n");
        else printf("The door cannot be opened.\n");
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章