Step6.1.5 hdu1879继续畅通工程(克鲁斯卡尔)

Step6.1.5 hdu1879继续畅通工程

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 11442    Accepted Submission(s): 5011

 

 

Problem Description

省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。

 

 

Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N (1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。

 

当N为0时输入结束。

 

 

Output

每个测试用例的输出占一行,输出全省畅通需要的最低成本。

 

 

Sample Input

3

1 2 1 0

1 3 2 0

2 3 4 0

3

1 2 1 0

1 3 2 0

2 3 4 1

3

1 2 1 0

1 3 2 1

2 3 4 1

0

 

 

Sample Output

3

1

0

 

 

Author

ZJU

 

 

Source

浙大计算机研究生复试上机考试-2008年

题解:

这道题继续是求最小生成树,还是克鲁斯卡尔算法。公路建成的城市,放到生成树中,然后再在将其他的顶点放到生成树中。

源代码:

#include <iostream>

#include <algorithm>

#include <stdio.h>

 

using namespace  std;

 

struct Road

{

   intc1,c2,value;

}rd[10050];

int  node[105];

 

void init()

{

   memset(node,-1,sizeof(node));

}

 

bool mycmp(const Road &x,const Road &y)

{

   if(x.value< y.value)

     returntrue;

   else

     returnfalse;

}

 

int find_set(int x)

{

   if(node[x]== -1)

     returnx;

   returnnode[x] = find_set(node[x]);

}

 

bool merge(int x,int y)

{

   intr1 = find_set(x);

   intr2 = find_set(y);

   if(r1== r2)

     return0;

   if(r1< r2)

     node[r2] = r1;

   else

     node[r1] = r2;

   return1;

}

 

int main()

{

   intn;

   while(scanf("%d",&n) != EOF && n)

   {

     init();

     intm = n*(n-1)/2;

     inta,b,c,d;

     intnum = 0,count = 0;

     for(int i = 0;i < m;i++)

     {

        scanf("%d%d%d%d",&a,&b,&c,&d);

        if(!d)

        {

          rd[num].c1 = a;

          rd[num].c2 = b;

          rd[num++].value = c;

        }

        else

        {

          if(merge(a,b))

             count++;

        }

     }

 

     sort(rd,rd+num,mycmp);

     intsum = 0;

     for(int i = 0;i < num;i++)

     {

        if(count== n-1)

          break;

        if(merge(rd[i].c1,rd[i].c2))

        {

          count ++;

          sum+=rd[i].value;

        }

     }

     printf("%d\n",sum);

   }

}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章