Step5.2.3 hdu 1800Flying to the Mars

Time Limit: 5000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 142 AcceptedSubmission(s): 75

 

Problem Description

 

 

In the year 8888, the Earth is ruled by thePPF Empire . As the population growing , PPF needs to find more land for thenewborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Herethe problem comes! How can the soldiers reach the Mars ? PPF convokes hissoldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shutup ! Do I have to remind you that there isn’t any road to the Mars from here!”PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although wehaven’t got wings ,I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’stime to learn to fly on a broomstick ! we assume that one soldier has one levelnumber indicating his degree. The soldier who has a higher level could teachthe lower , that is to say the former’s level > the latter’s . But the lowercan’t teach the higher. One soldier can have only one teacher at most ,certainly , having no teacher is also legal. Similarly one soldier can haveonly one student at most while having no student is also possible. Teacher canteach his student on the same broomstick .Certainly , all the soldier must havepracticed on the broomstick before they fly to the Mars! Magic broomstick isexpensive !So , can you help PPF to calculate the minimum number of thebroomstick needed .

For example :

There are 5 soldiers (A B C D E)with levelnumbers : 2 4 5 6 4;

One method :

C could teach B; B could teach A; So , A BC are eligible to study on the same broomstick.

D could teach E;So D E are eligible tostudy on the same broomstick;

Using this method , we need 2 broomsticks.

Another method:

D could teach A; So A D are eligible tostudy on the same broomstick.

C could teach B; So B C are eligible tostudy on the same broomstick.

E with no teacher or student are eligibleto study on one broomstick.

Using the method ,we need 3 broomsticks.

……

 

After checking up all possible method, wefound that 2 is the minimum number of broomsticks needed.

 

 

Input

Input file contains multiple test cases.

In a test case,the first line contains asingle positive number N indicating the number of soldiers.(0<=N<=3000)

Next N lines :There is only one nonnegativeinteger on each line , indicating the level number for each soldier.( less than30 digits);

 

 

Output

For each case, output the minimum number ofbroomsticks on a single line.

 

 

Sample Input

4

10

20

30

04

5

2

3

4

3

4

 

 

Sample Output

1

2

 

 

Author

PPF@JLU

 

 

Recommend

lcy

 

 

Statistic|Submit|Back

題解:

找到一系列數中,相等數最多的個數。不能用map會超時,用scanf可以讀取帶前綴0的數據。所以這道題就是scanf+sort。

源代碼:

#include <iostream>

#include <math.h>

#include <algorithm>

#include <stdio.h>

#include <string>

#include <map>

 

using namespace std;

 

int main()

{

   intn;

   intnum[5000];

   while(scanf("%d", &n) != EOF)

   {

     intmx = 1;

     for(int i = 0;i < n;i++)

        scanf("%d",&num[i]);

     sort(num,num+n);

     intcount = 1;

     for(int i = 0;i < n-1;i++)

     {

        if(num[i]== num[i+1])

        {

          count ++;

          if(count> mx)

             mx = count;

        }

        else        

          count = 1;

     }

     printf("%d\n",mx);

   }

}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章