Step5.2.1 hud 1075 What Are You Talking About

Step5.2.1 hud 1075

What Are You Talking About

 

Time Limit: 10000/5000 MS (Java/Others)Memory Limit: 102400/204800 K (Java/Others)

Total Submission(s): 146 AcceptedSubmission(s): 80

 

Problem Description

Ignatius is so lucky that he met a Martianyesterday. But he didn't know the language the Martians use. The Martian giveshim a history book of Mars and a dictionary when it leaves. Now Ignatius wantto translate the history book into English. Can you help him?

 

 

Input

The problem has only one test case, thetest case consists of two parts, the dictionary part and the book part. Thedictionary part starts with a single line contains a string "START",this string should be ignored, then some lines follow, each line contains twostrings, the first one is a word in English, the second one is thecorresponding word in Martian's language. A line with a single string"END" indicates the end of the directory part, and this string shouldbe ignored. The book part starts with a single line contains a string"START", this string should be ignored, then an article written inMartian's language. You should translate the article into English with thedictionary. If you find the word in the dictionary you should translate it andwrite the new word into your translation, if you can't find the word in the dictionaryyou do not have to translate it, and just copy the old word to yourtranslation. Space(' '), tab('\t'), enter('\n') and all the punctuation shouldnot be translated. A line with a single string "END" indicates theend of the book part, and that's also the end of the input. All the words arein the lowercase, and each word will contain at most 10 characters, and eachline will contain at most 3000 characters.

 

 

Output

In this problem, you have to output thetranslation of the history book.

 

 

Sample Input

START

from fiwo

hello difh

mars riwosf

earth fnnvk

like fiiwj

END

START

difh, i'm fiwo riwosf.

i fiiwj fnnvk!

END

 

 

Sample Output

hello, i'm from mars.

i like earth!

 

Hint

 

Huge input, scanf is recommended.

 

 

 

Author

Ignatius.L

 

題解:

字典樹,用getline和map解決。注意的是可能會存在特殊字符,或者是符號後面出現的詞也在字典裏。

源代碼:

#include <iostream>

#include <stdio.h>

#include <map>

#include <string>

#include <string.h>

using namespace std;

 

map<string,string> dic;

 

int main()

{

   string st,s1;

 

   cin >> st;

   cin >> st;

   while(st!= "END")

   {

     cin >> s1;

     dic[s1] = st;

     cin >> st;

   }

 

   cin >>st;

   getchar();

   while(getline(cin,st)&& st != "END")

   {

     intpos = 0,len = st.length();

     string a;

     while(pos!= len)

     {

       

        if(isalpha(st[pos]))

          a.push_back(st[pos]);

        else

        {

          map<string,string>::iteratorit;

          it = dic.find(a);

          if(it!= dic.end())

             cout<<it->second;

          else

             cout << a;

          cout << st[pos];

          a.clear();

        }

        pos++;

     }

     cout << endl;

   }

   return0;

}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章