hdu 1027 Ignatius and the Princess II (dfs+剪枝)?

Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8727 Accepted Submission(s): 5135

Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, “I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too.” Ignatius says confidently, “OK, at last, I will save the Princess.”

“Now I will show you the first problem.” feng5166 says, “Given a sequence of number 1 to N, we define that 1,2,3…N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it’s easy to see the second smallest sequence is 1,2,3…N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It’s easy, isn’t is? Hahahahaha……”
Can you help Ignatius to solve this problem?

Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub’s demand. The input is terminated by the end of file.

Output
For each test case, you only have to output the sequence satisfied the BEelzebub’s demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.

Sample Input
6 4
11 8

Sample Output
1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10


題意:給n,m,找出1~n這些數組成的序列中字典序第m小的序列。


直接dfs肯定會超了,想想找規律,難找。
超過八位數就找後八位數的排列就好了。。。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define N 1005
int n, m, l, cnt;
int num[N], vis[N];
void init()
{
    for( int i = 1 ; i <= n ; i ++ ){
        num[i] = i;
    }
}
void dfs( int a, int b )
{
    num[b] = a;
    if( b == n ) cnt ++;
    if( cnt == m ) return;
    for( int i = l ; i <= n ; i ++ ){
        if( !vis[i] ){
            vis[i] = 1;
            dfs( i, b+1 );
            if( cnt == m ) return;///
            vis[i] = 0;
        }
    }
    return;
}
int main()
{
    //freopen( "in.txt", "r", stdin );
    while( scanf( "%d%d", &n, &m ) != EOF ){
        memset( num, 0, sizeof( num ));
        memset( vis, 0, sizeof( vis ));
        cnt = 0;
        init();
        if( n < 8 ){
            l = 1;
            dfs( 1, 0 );
        }
        else{
            for( int i = 0 ; i <= n-8 ; i ++ ){
                vis[i] = 1;
            }
            l = n-8;///沒有這個還是會超
            dfs( n-8, n-8 );
        }
        for( int i = 0 ; i < n ; i ++ ){
            if( i ) cout<<" ";
            cout<<num[i+1];///這裏就這樣處理吧
        }cout<<endl;
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章