poj 1703 Find them, Catch them(並查集)

Find them, Catch them

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 47274 Accepted: 14570
Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

  1. D [a] [b]
    where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

  2. A [a] [b]
    where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.
    Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output

For each message “A [a] [b]” in each case, your program should give the judgment based on the information got before. The answers might be one of “In the same gang.”, “In different gangs.” and “Not sure yet.”
Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4
Sample Output

Not sure yet.
In different gangs.
In the same gang.


共有兩個幫派,D後面兩個數代表他們不在同一個幫派,A是詢問是否在一個幫派。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define N 211111
int p[N];
int fnd( int x ) { return p[x] = p[x] == x ? x : fnd( p[x] ); }
bool same( int x, int y ) { return fnd(x) == fnd(y); }
void unit( int x, int y )
{
    int u = fnd( x );
    int v = fnd( y );
    if( u != v ){
        p[u] = y;
    }
}
int main()
{
    //freopen( "in.txt", "r", stdin );
    int t, n, m, a, b;
    char ch;
    scanf( "%d", &t );
    while( t -- ){
        scanf( "%d%d", &n, &m );
        for( int i = 0 ; i <= 2*n ; i ++ ) p[i] = i;
        for( int i = 0 ; i < m ; i ++ ){
            getchar();
            scanf( "%c%d%d", &ch, &a, &b );
            //printf( "%c %d %d\n", ch, a, b );
            if( ch == 'D' ){
                if( !same( a, b+n ) && !same( a+n, b ) ){
                    unit( a, b+n );
                    unit( a+n, b );
                }
            }
            else if( ch == 'A' ){
                if( same( a, b ) || same( a+n, b+n ) ){
                    printf( "In the same gang.\n");
                }
                else if( same( a+n, b ) || same( a, b+n ) ){
                    printf( "In different gangs.\n");
                }
                else printf( "Not sure yet.\n");
            }
        }
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章