poj 2492 A Bug's Life(並查集)

A Bug’s Life

Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 39319 Accepted: 12790
Description

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output

The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.
Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!
Hint

Huge input,scanf is recommended.


按專家的想法異性bugs會互動,問這些bugs中是否找得出不滿足專家猜想的bugs。


#include <iostream>
#include <cstdio>
using namespace std;
#define N 4111
int p[N];
int fnd( int x ) { return p[x] = p[x] == x ? x : fnd( p[x] ); }
bool same( int x, int y ) { return fnd(x) == fnd(y); }
void unit( int x, int y )
{
    int u = fnd( x );
    int v = fnd( y );
    if( u != v ){
        p[u] = y;
    }
}
int main()
{
    //freopen( "in.txt", "r", stdin );
    int t, n, m, b1, b2, flg;
    scanf( "%d", &t );
    for( int k = 1 ; k <= t ; k ++ ){
        scanf( "%d%d", &n, &m );
        for( int i = 0 ; i <= 2*n ; i ++ ) p[i] = i;
        flg = 0;
        for( int i = 0 ; i < m ; i ++ ){
            scanf( "%d%d", &b1, &b2 );
            if( same( b1, b2 ) || same( b1+n, b2+n ) ) flg = 1;
//            else{
                unit( b1, b2+n );
                unit( b1+n, b2 );
//            }
        }
        if( k != 1 ) cout<<endl;
        printf( "Scenario #%d:\n", k );
        if( !flg ) printf( "No suspicious bugs found!\n" );
        else printf( "Suspicious bugs found!\n");
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章