POJ 3041 最小點覆蓋 二分圖最大匹配(hungary鄰接陣)

二分圖由n行(A集)、n列(B集)組成,(x,y)有隕石等價於x∈A -> y∈b 有一條有向邊。 消去x行等價於覆蓋x這個點。問題轉化爲求這個二分圖的最小點覆蓋。

Asteroids
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9839   Accepted: 5296

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.


OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source

 

 

//二分圖最大匹配,hungary算法,鄰接陣形式,複雜度O(m*m*n)
//返回最大匹配數,傳入二分圖大小m,n和鄰接陣mat,非零元素表示有邊
//match1,match2返回一個最大匹配,未匹配頂點match值爲-1
#include <string.h>
#include <stdio.h>
#define MAXN 510
#define _clr(x) memset(x,0xff,sizeof(int)*MAXN)

int hungary(int m,int n,int mat[][MAXN],int* match1,int* match2){
	int s[MAXN],t[MAXN],p,q,ret=0,i,j,k;
	for (_clr(match1),_clr(match2),i=0;i<m;ret+=(match1[i++]>=0))
		for (_clr(t),s[p=q=0]=i;p<=q&&match1[i]<0;p++)
			for (k=s[p],j=0;j<n&&match1[i]<0;j++)
				if (mat[k][j]&&t[j]<0){
					s[++q]=match2[j],t[j]=k;
					if (s[q]<0)
						for (p=j;p>=0;j=p)
							match2[j]=k=t[j],p=match1[k],match1[k]=j;
				}
	return ret;
}
int match1[MAXN],match2[MAXN],mat[MAXN][MAXN];

int main(){
    int n,k,i,j,x,y;
    scanf("%d%d",&n,&k);
    for (i=1;i<=k;i++){
        scanf("%d %d",&x,&y);
        x--;y--;
        mat[x][y]=1;
    }
/*    for (i=0;i<n;i++){
        for (j=0;j<n;j++) printf("%d ",mat[i][j]);
        printf("\n");
    }*/
    printf("%d\n",hungary(n,n,mat,match1,match2));
    return 0;
}


 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章