Labyrinth

Labyrinth

The northern part of the Pyramid contains a very large and complicated
labyrinth. The labyrinth is divided into square blocks, each of them
either filled by rock, or free. There is also a little hook on the
floor in the center of every free block. The ACM have found that two
of the hooks must be connected by a rope that runs through the hooks
in every block on the path between the connected ones. When the rope
is fastened, a secret door opens. The problem is that we do not know
which hooks to connect. That means also that the neccessary length of
the rope is unknown. Your task is to determine the maximum length of
the rope we could need for a given labyrinth.

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers C and R (3 <= C,R <= 1000) indicating the number of columns and rows. Then exactly R lines follow, each containing C characters. These characters specify the labyrinth. Each of them is either a hash mark (#) or a period (.). Hash marks represent rocks, periods are free blocks. It is possible to walk between neighbouring blocks only, where neighbouring blocks are blocks sharing a common side. We cannot walk diagonally and we cannot step out of the labyrinth.
The labyrinth is designed in such a way that there is exactly one path between any two free blocks. Consequently, if we find the proper hooks to connect, it is easy to find the right path connecting them.

Output
Your program must print exactly one line of output for each test case. The line must contain the sentence “Maximum rope length is X.” where Xis the length of the longest path between any two free blocks, measured in blocks.

Sample Input
2
3 3

#.#

7 6
#######
#.#.###
#.#.###
#.#.#.#
#…#
#######

Sample Output
Maximum rope length is 0.
Maximum rope length is 8.
Hint
Huge input, scanf is recommended.
If you use recursion, maybe stack overflow. and now C++/c 's stack size is larger than G++/gcc

題目大意:
在圖中找到距離最遠的兩個點,輸出它們之間的距離。
任意兩個點之間是連通的。

解題思路:
需要兩次bfs或dfs;先找到任意一個點,用bfs或dfs找到距離它最遠的點並標記,然後以這個點爲起點,用bfs或dfs找到距離它最遠的點,輸出二者之間的距離。

Code:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
#define N 1006
using namespace std;
char a[N][N];
int d[4][2]={1,0,-1,0,0,-1,0,1};//移動方向 
bool vis[N][N];//標記是否訪問過 
int n,m,ans;
struct node {
	int x,y;
	int step;//用步數計算二者之間的距離 
	friend bool operator > (node a,node b){//步數大的排前面,但沒什麼用 
		return a.step<b.step;
	}
};
node st,ag;
bool check(int x,int y){//判斷是否符合條件 
	if(x>=0&&x<n&&y>=0&&y<m&&!vis[x][y]&&a[x][y]!='#'){
		return 1;
	}
	return 0;
}
void bfs(node st){//bfs模板 
	queue<node>q;         
	q.push(st);
	while(!q.empty()){
		node no;
		no=q.front();
		q.pop();
		ag=no;
		ans=max(ans,no.step);
		for(int i=0;i<4;i++){
			node nx;
			nx.x=no.x+d[i][0];
			nx.y=no.y+d[i][1];
			if(check(nx.x,nx.y)){
				vis[nx.x][nx.y]=1;
				nx.step=no.step+1;
				q.push(nx);
			}
		}
	}
}
int main(){
	int t;
	cin>>t;
	while(t--){
		memset(vis,0,sizeof(vis));//消除之前的標記 
		ans=0;
		scanf("%d%d",&m,&n);
		for(int i=0;i<n;i++) scanf("%s",a[i]);
		for(int i=0;i<n;i++){
			for(int j=0;j<m;j++){
				if(a[i][j]=='.'){
					st.x=i,st.y=j;
					vis[st.x][st.y]=1;
					st.step=0;
					bfs(st);// 第一次查找 
					goto end;//goto跳出多層循環,也可以用flag標記跳出循環 
				}
				
			}
		}
		end:
		memset(vis,0,sizeof(vis));
		ans=0;
		ag.step=0;//每次查找前都要清除之前的數據 
		bfs(ag);//第二次查找 
		printf("Maximum rope length is %d.\n",ans);//注意輸出格式 
	}
	
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章