CD 路徑記憶

You have a long drive by car ahead. You have a tape recorder, but
unfortunately your best music is on CDs. You need to have it on tapes
so the problem to solve is: you have a tape N minutes long. How to
choose tracks from CD to get most out of tape space and have as short
unused space as possible. Assumptions: • number of tracks on the CD
does not exceed 20 • no track is longer than N minutes • tracks do not
repeat • length of each track is expressed as an integer number • N is
also integer Program should find the set of tracks which fills the
tape best and print it in the same sequence as the tracks are stored
on the CD

Input
Any number of lines. Each one contains value N, (after space) number of tracks and durations of the
tracks. For example from first line in sample data: N = 5, number of tracks=3, first track lasts for 1
minute, second one 3 minutes, next one 4 minutes
Output
Set of tracks (and durations) which are the correct solutions and string ‘sum:’ and sum of duration
times.
Sample Input
5 3 1 3 4
10 4 9 8 4 2
20 4 10 5 7 4
90 8 10 23 1 2 3 4 5 7
45 8 4 10 44 43 12 9 8 2
Sample Output
1 4 sum:5
8 2 sum:10
10 5 4 sum:19
10 23 1 2 3 4 5 7 sum:55
4 10 12 9 8 2 sum:45

題意:一張磁帶長度爲n的CD,有m首歌,問在這張CD上最多能刻長度多少的歌。
整首歌要全部被刻。

解題思路:簡單的01揹包問題,但輸出是個重點,需要用到路徑記憶。用vis數組標記第i首歌在長度爲j時被刻錄。最後輸出時,需要逆序訪問。

Code:

#include<iostream>
#include<cstring>
using namespace std;
int m,n;
const int maxn=1e5+7;
long long dp[maxn];
int vis[25][maxn];
int w[25];

int main(){
	while(cin>>m>>n){
		memset(dp,0,sizeof(dp));
		memset(vis,0,sizeof(vis));
		for(int i=0;i<n;i++) cin>>w[i];
		for(int i=0;i<n;i++){
			for(int j=m;j>=w[i];j--){
				if(dp[j-w[i]]+w[i]>=dp[j]){//判斷很重要,不然路徑存的位置與所求會不符 
					dp[j]=dp[j-w[i]]+w[i];
					vis[i][j]=1;//路徑記憶 
				}						
			}
		}
		int w1[25],q=0;
		for(int i=n-1,j=m;i>=0;i--){
			if(vis[i][j]){
				//cout<<w[i]<<" ";
				w1[q++]=w[i];
				j=j-w[i]; 
			}
		}
		for(int i=q-1;i>=0;i--){//與題目做到相同輸出 
			cout<<w1[i]<<" ";
		}
		printf("sum:%lld\n",dp[m]);
	}
	
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章