Java Beans ZOJ 3714

Java Beans

Time Limit: 2 Seconds      Memory Limit: 65536 KB

There are N little kids sitting in a circle, each of them are carrying some java beans in their hand. Their teacher want to select M kids who seated in M consecutive seats and collect java beans from them.

The teacher knows the number of java beans each kids has, now she wants to know the maximum number of java beans she can get from M consecutively seated kids. Can you help her?

Input

There are multiple test cases. The first line of input is an integer T indicating the number of test cases.

For each test case, the first line contains two integers N (1 ≤ N ≤ 200) and M (1 ≤ MN). Here N and M are defined in above description.The second line of each test case contains N integers Ci (1 ≤ Ci ≤ 1000) indicating number of java beans the ith kid have.

Output

For each test case, output the corresponding maximum java beans the teacher can collect.

Sample Input

2
5 2
7 3 1 3 9
6 6
13 28 12 10 20 75

Sample Output

16
158

題解:題意爲N個小朋友圍成一圈,每個小朋友手裏都有一些豆子,老師想搶連續的M個小朋友的豆子,問老師最多能搶多少?

一開始沒看清是連續的小朋友,直接排序,錯了一發……


#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<stdlib.h>
#include<time.h>
#include<string>
#include<math.h>
#include<map>
#include<queue>
#include<stack>
#define INF 0x3f3f3f3f
#define ll long long
#define For(i,a,b) for(int i=a;i<b;i++)
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
int n,m;
int x[405];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        mem(x,0);
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
        scanf("%d",&x[i]);
        int s=0,ans=0;
        for(int i=0;i<=n;i++)
        {
            for(int j=i;j<i+m;j++)
            {
                s+=x[j%n];
            }
            if(s>=ans)
                ans=s;
            s=0;
        }
        printf("%d\n",ans);
    }
}







發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章