SPY (map容器)

SPY

Time limit   1000 ms                    Memory limit         131072 kB

The National Intelligence Council of X Nation receives a piece of credible information that Nation Y will send spies to steal Nation X’s confidential paper. So the commander of The National Intelligence Council take measures immediately, he will investigate people who will come into NationX. At the same time, there are two List in the Commander’s hand, one is full of spies that Nation Y will send to Nation X, and the other one is full of spies that Nation X has sent to Nation Y before. There may be some overlaps of the two list. Because the spy may act two roles at the same time, which means that he may be the one that is sent from Nation X to Nation Y, we just call this type a “dual-spy”. So Nation Y may send “dual_spy” back to Nation X, and it is obvious now that it is good for Nation X, because “dual_spy” may bring back NationY’s confidential paper without worrying to be detention by NationY’s frontier So the commander decides to seize those that are sent by NationY, and let the ordinary people and the “dual_spy” in at the same time .So can you decide a list that should be caught by the Commander?

A:the list contains that will come to the NationX’s frontier.

B:the list contains spies that will be sent by Nation Y.

C:the list contains spies that were sent to NationY before.


Input
There are several test cases.
Each test case contains four parts, the first part contains 3 positive integers A, B, C, and A is the number which will come into the frontier. B is the number that will be sent by Nation Y, and C is the number that NationX has sent to NationY before.
The second part contains A strings, the name list of that will come into the frontier.
The second part contains B strings, the name list of that are sent by NationY.
The second part contains C strings, the name list of the “dual_spy”.
There will be a blank line after each test case.
There won’t be any repetitive names in a single list, if repetitive names appear in two lists, they mean the same people.
Output
Output the list that the commander should caught (in the appearance order of the lists B).if no one should be caught, then , you should output “No enemy spy”.
Sample Input
8 4 3
Zhao Qian Sun Li Zhou Wu Zheng Wang
Zhao Qian Sun Li
Zhao Zhou Zheng
2 2 2
Zhao Qian
Zhao Qian
Zhao Qian
Sample Output
Qian Sun Li
No enemy spy


題解:題目大意爲,X國家得知Y國家將要派間諜到X國,X國嚇尿了,趕緊查看最近入境人員,並且想到了X國以前派到Y國的間諜……求X國要抓的人……

每組數據四行:

第一行:三個數a,b,c;

第二行:X國最近入境人員

第三行:Y國將要派到X國的間諜(注意,只是將要,間諜不一定過境,必定X國的邊防不是吃素的……)

第四行:X國以前派到Y國的間諜



思路:很簡單,只要抓第三行中第一行出現過且第四行未出現的人就好了……


#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<stdlib.h>
#include<time.h>
#include<string>
#include<math.h>
#include<map>
#include<queue>
#include<stack>
#define INF 0x3f3f3f3f
#define ll long long
#define For(i,a,b) for(int i=a;i<b;i++)
#define sf(a)  scanf("%d",&a)
#define sfs(a)  scanf("%s",a)
#define sff(a,b)  scanf("%d%d",&a,&b)
#define pf(a) printf("%d\n",a)
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
string x,y[1000];
int main()
{
    int a,b,c;
    while(~scanf("%d%d%d",&a,&b,&c))
    {
        map<string,int>m;
        map<string,int>mm;
        m.clear();mm.clear();
        For(i,0,a )
        {
            cin>>x;m[x]++;         
        }
        For(i,0,b)cin>>y[i];
        For(i,0,c)
        {
            cin>>x;
            mm[x]++;
        }
        int flag=0;
        For(i,0,b)
        {
            if(m[y[i]]==1&&mm[y[i]]==0) // 第二行出現的且第四行未出現的
            {
                if(flag)
                    cout<<" "<<y[i];
                else cout<<y[i];
                flag=1;
            }
        }
        if(!flag)cout<<"No enemy spy";
        printf("\n");
    }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章