1099. Build A Binary Search Tree (30)

1099. Build A Binary Search Tree (30)

標籤: PAT 解題報告


A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
實例圖片
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format “left_index right_index”, provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.
Output Specification:
For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
Sample Output:
58 25 82 11 38 67 45 73 42

這題是9月4日的模擬考的題目,當時沒做出來.其實很簡單,只不過因爲實習了一個暑假,數據結構的一些東西已經忘得精光了,開學又是實驗周,一點時間都抽不出來去複習,感覺這次的考試凶多吉少.

廢話不多說,下面還是繼續寫一下這個題目.
題目的意思主要就是給定一個二叉樹和一個序列,讓我們寫程序把這個序列填充爲一個二叉搜索樹.並且按照層序輸出.

難點在於怎麼處理輸入,根據輸入構造出相應的二叉樹的結構.
二叉樹的結構構造好後,就可以用中序遍歷將數據填充進去.

我自己第一次寫的代碼沒有提交通過,主要是因爲錯誤理解了題意.我以爲節點出現的順序是按照順序的,但是實際上並不是這樣.所以提交失敗.另外由於不知道怎麼在遞歸中將數據填充進去,後來看了別人的解法才寫出來.

下面貼一下看了別人的解法之後寫出來的AC代碼.

#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;


int Left[105];
int Right[105];
int a[105];
int b[105];


void DFS(int now ,int &x){
    if(now < 0)
        return;
    DFS(Left[now],x);
    b[now] = a[x++];
    DFS(Right[now],x);
}

int main(){
#ifndef ONLINE_JUDGE
    freopen("data.in","r",stdin);
    freopen("data.out","w",stdout);
#endif
    int N ;
    cin >> N;
    for(int i = 0; i < N ; i ++){
        cin >> Left[i] >> Right[i];
    }
    for(int i = 0; i < N ; i ++){
        cin >> a[i];
    }
    sort(a,a+N);
    int n = 0;
    DFS(0,n);
    queue<int> q;
    q.push(0);
    vector<int> answer;
    while(!q.empty()){
        int node = q.front();
        q.pop();
        answer.push_back(b[node]);
        if(Left[node] != -1) q.push(Left[node]);
        if(Right[node] != -1) q.push(Right[node]);
    }
    for(int i = 0; i < answer.size(); i ++){
        cout << answer[i] << (i == answer.size() - 1?"":" ");
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章