POJ 2135 —— 最小費用流

Farm Tour
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9786   Accepted: 3603

Description

When FJ's friends visit him on the farm, he likes to show them around. His farm comprises N (1 <= N <= 1000) fields numbered 1..N, the first of which contains his house and the Nth of which contains the big barn. A total M (1 <= M <= 10000) paths that connect the fields in various ways. Each path connects two different fields and has a nonzero length smaller than 35,000. 

To show off his farm in the best way, he walks a tour that starts at his house, potentially travels through some fields, and ends at the barn. Later, he returns (potentially through some fields) back to his house again. 

He wants his tour to be as short as possible, however he doesn't want to walk on any given path more than once. Calculate the shortest tour possible. FJ is sure that some tour exists for any given farm.

Input

* Line 1: Two space-separated integers: N and M. 

* Lines 2..M+1: Three space-separated integers that define a path: The starting field, the end field, and the path's length. 

Output

A single line containing the length of the shortest tour. 

Sample Input

4 5
1 2 1
2 3 1
3 4 1
1 3 2
2 4 2

Sample Output

6

Source

題意是給你n塊地,m條路,讓你輸出從1點出發經過所有點,回到1點的最短距離,保證每條道路只通過一次

思路:我們可以把問題轉化爲從1到n,沒有公共邊的兩條路徑,相當於求流量爲2的最小費用流。

#include <cstdio>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <map>
#include <string>
#include <stack>
#include <cctype>
#include <vector>
#include <queue>
#include <set>
#include <utility>
#include <cassert>
using namespace std;
///#define Online_Judge
#define outstars cout << "***********************" << endl;
#define clr(a,b) memset(a,b,sizeof(a))
#define lson l , mid  , rt << 1
#define rson mid + 1 , r , rt << 1 | 1
#define mk make_pair
#define FOR(i , x , n) for(int i = (x) ; i < (n) ; i++)
#define FORR(i , x , n) for(int i = (x) ; i <= (n) ; i++)
#define REP(i , x , n) for(int i = (x) ; i > (n) ; i--)
#define REPP(i ,x , n) for(int i = (x) ; i >= (n) ; i--)
const int MAXN = 10000 + 50;
const int sigma_size = 26;
const long long LLMAX = 0x7fffffffffffffffLL;
const long long LLMIN = 0x8000000000000000LL;
const int INF = 0x7fffffff;
const int IMIN = 0x80000000;
#define eps 1e-8
const int MOD = (int)1e9 + 7;
typedef long long LL;
const double PI = acos(-1.0);

#define Bug(s) cout << "s = " << s << endl;
///#pragma comment(linker, "/STACK:102400000,102400000")

int n , m;
int a[MAXN] , b[MAXN] , c[MAXN];
typedef pair<int , int> pi;
///表示邊的結構體(終點,容量,費用,反向邊)
struct edge{int to , cap, cost , rev;};
int V;///頂點數
vector<edge> G[MAXN];///圖的鄰接表表示
int h[MAXN];///頂點的勢
int dist[MAXN];///最短距離
int prevv[MAXN] , preve[MAXN];///最短路中的前驅節點和對應的邊
///向圖中增加一條從from到to容量爲cap費用爲cost的邊
void add_edge(int from , int to , int cap , int cost)
{
    G[from].push_back((edge){to , cap ,cost , G[to].size()});
    G[to].push_back((edge){from , 0 , -cost , G[from].size() - 1});
}
///求解從s到t流量爲f的最小費用流
///如果沒有流量爲f的流,則返回-1
int min_cost_flow(int s , int t , int f)
{
    int res = 0;
    fill(h , h + V ,0);///初始化h
    ///使用Dijkstra算法更新h
    while(f > 0)
    {
        priority_queue<pi , vector<pi> , greater<pi> > que;
        fill(dist , dist  + V , INF);
        dist[s] = 0;
        que.push(pi(0 , s));
        while(!que.empty())
        {
            pi p = que.top() ; que.pop();
            int v = p.second;
            if(dist[v] < p.first)continue;
            for(int i = 0 ; i < G[v].size() ; i++)
            {
                edge &e = G[v][i];
                if(e.cap > 0 && dist[e.to] > dist[v] + e.cost + h[v] - h[e.to])
                {
                    dist[e.to] = dist[v] + e.cost + h[v] - h[e.to];
                    prevv[e.to] = v;
                    preve[e.to] = i;
                    que.push(pi(dist[e.to] , e.to));
                }
            }
        }
        ///不能再增廣
        if(dist[t] == INF)return -1;
        for(int v = 0 ; v < V; v++)h[v] += dist[v];
        ///沿s到t的最短路儘量增廣
        int d = f;
        for(int v = t ; v != s ; v = prevv[v])
        {
            d = min(d , G[prevv[v]][preve[v]].cap);
        }
        f -= d;
        res += d * h[t];
        for(int v = t ; v != s ; v = prevv[v])
        {
            edge & e = G[prevv[v]][preve[v]];
            e.cap -= d;
            G[v][e.rev].cap += d;
        }
    }
    return res;
}
void solve()
{
    int s = 0 , t = n - 1;
    V = n;
    for(int i = 0 ; i < m;  i++)
    {
        add_edge(a[i] - 1 , b[i] - 1 , 1  , c[i]);
        add_edge(b[i] - 1 , a[i] - 1 , 1 , c[i]);
    }
    printf("%d\n" , min_cost_flow(s , t , 2));
}
int main()
{
    while(~scanf("%d%d" , &n , &m))
    {
        for(int i = 0  ; i < m ; i++)
        {
            scanf("%d%d%d" , &a[i] , &b[i] , &c[i]);
        }
        solve();
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章