18秋第三題 PAT甲級 1150 Travelling Salesman Problem (25分) 簡單圖論

題目

The "travelling salesman problem" asks the following question: "Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?" It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from "https://en.wikipedia.org/wiki/Travelling_salesman_problem".)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:

n C​1​​ C​2​​ ... C​n​​

where n is the number of cities in the list, and C​i​​'s are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

  • TS simple cycle if it is a simple cycle that visits every city;
  • TS cycle if it is a cycle that visits every city, but not a simple cycle;
  • Not a TS cycle if it is NOT a cycle that visits every city.

Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8

名詞解釋

1.undirected graph
無向圖,就是A和B點有連線的話,是雙向的
在代碼層面就是int G[maxn][maxn],存邊的時候G[a][b]=G[b][a]=cost

2.cycle
迴路,就是說圖的頂點序列中,第一個頂點和最後一個頂點相同

3.simple cycle
簡單迴路,就是圖的頂點序列中,除了第一個頂點和最後一個頂點相同外,其餘頂點不重複出現的迴路

題目大意

給出無向圖和頂點序列,判斷是不是旅行商迴路和簡單迴路。

分析

這道題的輸出要求是這樣的:

  • TS simple cycle if it is a simple cycle that visits every city;
  • TS cycle if it is a cycle that visits every city, but not a simple cycle;
  • Not a TS cycle if it is NOT a cycle that visits every city.

稍作整理,可以發現這道題的判斷邏輯基本上照搬輸出的要求:
1.Not a TS cycle:頂點序列首尾不同 或者 沒有遍歷每個城市
2.TS cycle:遍歷了每個城市但是頂點序列有重複
3.TS simple cycle:不用單獨判斷了,除了前兩種情況其餘都是

這就是“簡單圖論”題目的典型,在PAT甲級考試挺常見的圖論考法。

滿分代碼

#include<iostream>
#include<vector>
#include<set>
#include<cctype>
using namespace std;
const int maxn=205;
#include "0.h"
int n,m,k,u,w,c;
int G[maxn][maxn];
int main(){
    cin>>n>>m;
    for(int i=0;i<m;i++){
        scanf("%d %d %d",&u,&w,&c);
        G[u][w]=G[w][u]=c;
    }
    cin>>k;
    int sp=1,sd=9999999;
    for(int i=1;i<=k;i++){
        cin>>u;
        vector<int> v(u+5);
        set<int> s;
        int dis=0,f=0;
        for(int i=1;i<=u;i++){
            scanf("%d",&v[i]);
            s.insert(v[i]);
            if(i!=1){
                dis+=G[v[i-1]][v[i]];
                if(G[v[i-1]][v[i]]==0)f=1;
            }
        }
        printf("Path %d: ",i);
        if(f==1) printf("NA ");
        else printf("%d ",dis);
        if(s.size()!=n || v[1]!=v[u] ||f==1){
            printf("(Not a TS cycle)\n");
            continue;
        }else if(u>n+1){
            printf("(TS cycle)\n");
        }else{
            printf("(TS simple cycle)\n");
            
        }
        if(sd>dis){
            sd=dis;
            sp=i;
        }
    }
    printf("Shortest Dist(%d) = %d\n",sp,sd);
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章