hdu 2955 Robberies

Problem Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output

2
4
6



一個關於揹包的題目。。題目的意思就是搶劫銀行,一個是搶劫的
錢,一個是被抓的概率,。  然後問最後在有限的概率之內,
可以搶到多少的錢。  那麼,我們可以將被抓轉化成不被抓,
所以,在輸入的時候。轉化概率,。爲1-p[i]; 然後呢,求全都搶到的
總錢數。之後,就是01揹包的模型,在一個概率的數組裏面,
只要在有限的安全概率之上,就可以了、、
#include<iostream>
using namespace std;
int max(int x,int y)
{
	return x>y?x:y;
}
int main()
{
	int bbs,n;
	double m,p[110];
	double a[10010]; //安全係數 
	int s[110];
	cin>>bbs;
	int i,j;
	while(bbs--)
	{
		cin>>m;
		m=1-m;
		cin>>n;
		int sum=0;
		for(i=0;i<n;i++)
		{
			cin>>s[i];
			cin>>p[i];
			p[i]=1-p[i];//沒被抓的概率 
			sum+=s[i];
		}
		for(i=0;i<=sum;i++)
		{
			a[i]=0;
		}
		a[0]=1;//沒搶的時候
		for(i=0;i<n;i++)
		{
			for(j=sum;j>=s[i];j--)
			{
				a[j]=max(a[j],a[j-s[i]]*p[i]);
			}
		}
		for(i=sum;i>=0;i--)
		{
			if(a[i]-m>0.000000001)
			{
				cout<<i<<endl;
				break;
			}
		}
	}
	return 0;
} 


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章