hdu 2124 Repair the Wall

Problem Description
Long time ago , Kitty lived in a small village. The air was fresh and the scenery was very beautiful. The only thing that troubled her is the typhoon.

When the typhoon came, everything is terrible. It kept blowing and raining for a long time. And what made the situation worse was that all of Kitty's walls were made of wood.

One day, Kitty found that there was a crack in the wall. The shape of the crack is 
a rectangle with the size of 1×L (in inch). Luckly Kitty got N blocks and a saw(鋸子) from her neighbors.
The shape of the blocks were rectangle too, and the width of all blocks were 1 inch. So, with the help of saw, Kitty could cut down some of the blocks(of course she could use it directly without cutting) and put them in the crack, and the wall may be repaired perfectly, without any gap.

Now, Kitty knew the size of each blocks, and wanted to use as fewer as possible of the blocks to repair the wall, could you help her ?
 

Input
The problem contains many test cases, please process to the end of file( EOF ).
Each test case contains two lines.
In the first line, there are two integers L(0<L<1000000000) and N(0<=N<600) which
mentioned above.
In the second line, there are N positive integers. The ith integer Ai(0<Ai<1000000000 ) means that the ith block has the size of 1×Ai (in inch).
 

Output
For each test case , print an integer which represents the minimal number of blocks are needed.
If Kitty could not repair the wall, just print "impossible" instead.
 

Sample Input
5 3 3 2 1 5 2 2 1
 

Sample Output
2 impossible
一個貪心的題目,題目的意思就是 用木塊來補縫,要求用的木塊最少。 所以就從大優先。。。
而且 木塊可以分割。。所以,當在最後的時候 , 直接分割,計數加一即可;;
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{
	int l,n,i,j,t,q;
	int s[650];
	while(cin>>l>>n)
	{
		for(i=0;i<n;i++)
		{
			cin>>s[i];
		}
		int t=0,q=0,k=0;
		sort(s,s+n);
		for(i=n-1;i>=0;i--)
		{
			if(s[i]+k<l)
			{
				k+=s[i];
				t++;
			}
			else 
			{
				t++;
				q=1;
				cout<<t<<endl;
				break;
			}
		
		}
		if(q==0)
		cout<<"impossible"<<endl;
	}
	
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章