hdu 1671 Phone List

Problem Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES


本題的題意是,給你n個串的電話號碼。問有沒有可能一個電話號碼是其他的 號碼的前綴,、
比如911 它就是91156的前綴。如果有的話輸出NO。沒有則輸出YES
這題的解法就是字典樹,首先套用字典樹的模板,建立字典樹,注意清空root
然後將輸入的電話號碼存入字典樹裏面,然後尋找遍歷字典樹,如果遍歷完一個電話號碼
之後,看後面的節點是否爲空,如果不爲空,說明有其他的電話號碼是以這個前綴的,標記,
然後判斷輸出;,,而且注意一點就是結束之後記得清空,不然很容易mle。具體實現如下:

#include<iostream>
#include<cstring>
#include<stdio.h>
#include<stdlib.h>
using namespace std;
struct node
{
	struct node *next[10];
};

struct node *root;
void charu(char *qq)
{
	struct node *now1,*now2;
	int i,j;
	int l=strlen(qq);
	now1=root;
	
	for(i=0;i<l;i++)
	{
		int k=qq[i]-'0';
		if(now1->next[k]) now1=now1->next[k];
		else 
		{
			now2=new struct node;
			for(j=0;j<10;j++) now2->next[j]=0;
			now1->next[k]=now2;
			now1=now2;
		}
	}
}
int find(char *s)
{
	int i;
	struct node *now;
	now=root;
	int flag;
	int l=strlen(s);
	
	for(i=0;i<l;i++) now=now->next[s[i]-'0'];
	flag=0;
	for(i=0;i<10;i++) 
	if(now->next[i])
	{
		flag=1; break;
	}

}
void qing(struct node *pp)
{
	int i;
	for(i=0;i<10;i++)
	if(pp->next[i])
	qing(pp->next[i]);
	delete(pp);
}

int main()
{
	int bbs,n,i,j,ans;
	char ss[10010][12];
	cin>>bbs;
	while(bbs--)
	{
		cin>>n;
		root=new struct node;
		for(i=0;i<10;i++) root->next[i]=0;
		
		for(i=0;i<n;i++)
		{
			scanf("%s",ss[i]);
			charu(ss[i]);
		}
		ans=0;
		for(i=0;i<n;i++)
		{
			ans=find(ss[i]);
			if(ans)  break;
		}
		if(ans)  cout<<"NO"<<endl;
		else cout<<"YES"<<endl;
		qing(root);
	}
	return 0;
	
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章